This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 33 replies, has 2 voices.

Last updated by Itamar 3 months, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
March 8, 2019 at 10:52 am #3291400

Yves

Hi,

Every time the client makes changes in the WordPress language pages or create new pages in the languages, there are a lot of requests to our server and our server goes down.

How come there are that manny request in the string translations when the client makes changes or creates pages?

Our hosting scanned the requests and they are all made by the WPML plugin.

Thanks in advance.

Greetings,
Joke

March 10, 2019 at 11:05 am #3303797

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Joke.

I'll help you recognize and fix as much as possible the overload of requests to your server.

Could you please go over the following tutorial that we have and make sure that all the suggestions in this tutorial are implemented on your site?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
If you follow all of the above suggestion is it helping to solve the overload on the server and thus not causing the server to go down?

In addition to the above, I can also see that you are using the W3 Total Cache plugin on your site. This plugin is one of the best cache plugins for WordPress. But if configured incorrectly can cause the opposite desired result and slow down your site.
Could you please the following documentation and see that everything is set properly with the W3TC plugin on your site?
https://wpml.org/documentation/plugins-compatibility/optimize-multilingual-website-performance-using-w3-total-cache/

Thanks,
Itamar.

March 11, 2019 at 11:01 am #3310007

Yves

Hi,

I have checked al these settings and the only setting that I have changed is the following:
For improving how WPML String Translation works, go to the WPML -> Theme and plugin localization page. There, in the Localization options section, under How to translate strings in themes and plugins?, be sure to select the Translate themes and plugins using WPML’s String Translation only (don’t load .mo files) option.

Now the website keeps on loading and we can not login to the wp-admin...

Is there another problem?

Greetings,
Joke

March 11, 2019 at 3:34 pm #3314431

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Joke.

The option 'Translate themes and plugins using WPML’s String Translation only (don’t load .mo files) option' is recommended by us as it saves DB queries for strings. But when first enabling this option WPML performs this the loading of the strings from .mo files to the DB. While this is happening (it can take a while, depending on your site), there can be a load of DB queries. Maybe that was the problem that you were having after enabling this option. But now when I check your site on the front-end and also on the login address here, it is loading OK.
hidden link
Can you see that it is OK now?
What is the current situation with the Overload of request to your server?

March 11, 2019 at 3:37 pm #3314483

Yves

Hi,

The wp-admin pages kept on loading, so we had to contact our hosting and they deactivated the plugin WPML. If we activate the plugin, the site goes down and all our other websites on that hosting to.

So the problem isn't solved at all.

If we activate the plugin wpml everything goes down again.
What can we do next?

Greetings,
Joke

March 12, 2019 at 11:02 am #3321207

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Joke.

Sometimes this can also be the result of your hosing. Especially if you are on shared hosting plan. From our documentation:
Hosting services usually provide shared hostings as a cheap way of having your WordPress site. However, if you are creating a complex site, you should consider using a private server or update to a higher hosting package to have all the resources that your site may need.
https://wpml.org/faq/prevent-performance-issues-with-wpml/#checking-your-hosting-setup

Since every time you are enabling WPML this issue happens, we need to check this issue on our test server.
Can you please migrate your site to our test server?
The process is quite easy, and you will find all the explanations about it in the next private reply that I'll add in a few minutes after I set up our test server for your site.

Thanks,
Itamar.

March 14, 2019 at 8:47 am #3341509

Yves

Hi,

We've just created a test environment on a VPS with good amount of resources. We still have this problem, so it shouldn't be caused by bad hosting.

Since the website is very big to migrate, I suggest you can do whatever test you want on our test server. How can I create a private message to send all the details to you?

March 14, 2019 at 9:22 pm #3348567

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

March 18, 2019 at 4:45 pm #3371673

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked things on your site. I've found out that even in a minimum environment when I activate the String Translation add-on the site breaks. I get 504. Only if I rename the String Translation plugin through FTP I can access the site again. I've enabled the debug log and now I'm consulting our second tier supporters about this problem. When I have more information from them I'll get back to you here.

Thank you for your patience.

March 20, 2019 at 3:56 pm #3390163

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

After checking the errors that we can see in the debug log, our second tier supporter asked me to check the file's permission for the file where the error is coming from (class-wpml-register-string-filter.php) and also compare it to the permission of the sitepress.php main file in sitepress-multilingual-cms (main WPML plugin). I've checked that and returned an answer to him. And now I'm waiting for further instructions. I'll keep you updated here.

Thank you for your patience.
Itamar.

March 24, 2019 at 5:57 pm #3448907

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Our second tier supporter instructed me to check if the problem still happens with the copy of your site on my local server. And I can see that it does happen. So I've escalated this issue to our second tier supporters and they will continue to debug it.

We'll keep you updated here on any news regarding this issue.

Thank you for your patience.
Itamar.

March 26, 2019 at 6:50 pm #3465765

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Our second tier supporter has found the problem on your site. Here is the explanation that he gave me. "It is an error in the index structure of the table icl_string_translations. There is a missing UNIQUE index for string language - and thus the problem happens."
Our second tier supporter has fixed this issue on your site here hidden link
Can you please confirm that it is fixed now?

Thanks,
Itamar.

April 2, 2019 at 1:31 pm #3517717

Yves

Hi,

Thanks for you help. It looks like the plug-ins work together again.

- What exactly did the 2nd tier supporter do? So we can reproduce in production environment.
- The website still is very slow. It looks like WPML is responsible for this load time. hidden link is an exact copy of vps.inontwikkeling.be. On sensotec.be everything runs very smooth since we disabled WPML there.

On vps.inontwikkeling.be the WPML plug-in is active and the website is slow again.

> What can we do about this speed issue?

April 2, 2019 at 7:15 pm #3520247

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'm asking our second tier supporter to specify about the DB fix, and I'll get back to here when I have an answer from him.

Could you please tell me where and how I can see that your website is slow?
Is it happening on specific pages?

Thanks,
Itamar.

April 3, 2019 at 7:51 am #3523247

Yves

Hi,

Basically every page is slower with the WPML plugin activated.
For example: when you switch from homepage to "products".

On sensotec.be the load time is 1.52s (WPML deactivated)
On vps.inontwikkeling.be the load time is 6.63s (WPML activated)

We need the solution very fast since our client is getting frustrated because of this problem.

The topic ‘[Closed] Overload of request to our server’ is closed to new replies.