This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Bobby 7 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
March 2, 2019 at 12:06 am #3263352

yvonneS-4

Tell us what you are trying to do?
I am trying to update translation in a certain string, but when I save it still uses the old translation
Is there any documentation that you are following?
I couldn't find any
Is there a similar example that we can see?
I am sure it is like this for al translations
What is the link to your site?
hidden link

March 2, 2019 at 7:37 am #3264295

SergeyR
Supporter

Hello,
have you tried to check "Use my translation" and save? And what happened after you saved it?

Regards,

March 2, 2019 at 2:35 pm #3264669

yvonneS-4

1. Nothing happpens after I save it, I think.
Where can I find that specific string in the website? There are 3 "View all". two say "default" one "engage". Where can I find those individually. It may be that I looked at the wrong one.

2 Also I do not understand why my theme and the string partially are in German now. I would like to reverse this. In the picture I attached you can see that the first view all Says "translation complete" and the 2nd one says it in German.( ueberstezung abgeschlossen) I think it would be better if it could stay in English.

Thank you

March 5, 2019 at 12:47 am #3270970

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

in the front end where can i see the "view all" string that you need to translate? if possible please point me to it with a link or screenshot.

String translation will simply register all translatable strings that are provided by your theme(s)/plugins , once you translate it the translation should show as expected in the front end , unless the checkbox has not been checked or the wrong string was translated.

regarding the language in the backend , what language is set as default within WPML->languages?

if you are still experiencing an issue with this please provide me with the exact location in the front end of the string in question and i will take a closer look at the backend.

NOTE : please make sure you perform a backup before providing access

March 6, 2019 at 6:30 pm #3280958

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the description and screenshot !

1. If you have forgotten the original string , i would recommend viewing the default language as it should be translated , and if that is not an option with String Translation you can search the translation as well

go to WPML->String Translation->add the string in the search box and check the box for "include translations" and search.

once you get the results then you can examine the domain and judge if that is the correct string

for example i can see the string alle sahen for View All is under the domain Engage

2. Now i have found the string , i click on translations , click on the German field and add my new translation , then i just check the box for "Translation is complete" and save.

this is the whole process no need to do anything more.

ex. i changed "alle sehen" to "alle Ansehen" for a test and it works as expected.

3. When you set the language to German wordpress pulls translations for the backend , this can be the reason some stuff shows translated and some does not, if the translation does not exist in the WP database then it wont show. Going into Your profile-> set the language to English and this should work

March 6, 2019 at 8:57 pm #3281243

yvonneS-4

Thank you, I could save it. Strange.

have one more question. I have attached screenshot. There are 3 "View all" strings displayed. How do I know which one is which? Is there a link to the page somewhere or what does DOMAIN mean in that case. How do I know which on would show on the portfolio page? Lets say there were 4 more pages with "view more" somewhere in this site.

Thank you.

March 6, 2019 at 8:59 pm #3281244

yvonneS-4

forgot screenshot

March 7, 2019 at 12:46 am #3281641

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Notice on the left it says Default , Default , and engage

you can see that the "engage" domain is the one you want. As default corresponds to your site's default WordPress strings.

now lets say you are confused on which one is the correct and the domain naming does not help, you can simply translate all of them one by one and see which one changes the front end ,there is no issues that could arise out of this

The topic ‘[Closed] Overwrite and save existing translations’ is closed to new replies.