Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 1 year, 5 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 14, 2020 at 1:10 pm #6592861

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case I would appreciate if you could send me the plugin files so I can setup everything in order to replicate the issue. I will help to speed up the process and avoid any server issues when trying to install the plugin. The next reply is marked as private so you can safely provide the plugin files in a zip folder, I recommend you to upload it to a file sharing service, then you can paste the download url here and I will proceed right away. Also, please, don't forget to include any temporary license if it is something required for the plugin activation.

Thank you for your collaboration and understanding, have a nice day.

July 15, 2020 at 7:57 am
July 15, 2020 at 5:25 pm
July 15, 2020 at 5:25 pm #6606489

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when you are ready. Thanks.

July 23, 2020 at 11:19 am #6660721

michelB-16

Hello,

Sorry for the late response, we tried to replicate the problem but it did not work.

Do you have other suggestions? Thanks in advance.

July 24, 2020 at 4:53 pm #6672751

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I checked the test site at: hidden link and noticed the Oxygen is properly installed but it seems you didn't replicate the issue there.

Can you please, try to replicate the issue following the exact same steps you did in your website? You can login with the credentials provided in my previous private reply (https://wpml.org/forums/topic/oxygen-template-loading-different-content-when-logged-in-and-not-logged-in-users/page/2/#post-6606485).

Also, please, don't forget to provide us with the full detailed step by step instructions on how to replicate it. It will help us in the debug process and also will be of help to escalate it to our compatibility team properly.

Thank you for your collaboration and continued patience, have a nice day.

July 27, 2020 at 2:09 pm #6683871

michelB-16

Hi,

Thanks for the response. We tried again to replicate the problem but it didn't happen. It's also very dificult to give a right detailed instruction because the website changed a lot and took a long time to built.

The only way to replicate the problem is to copy the website because it is very large and complex.

We also have a problem with the Gutenberg editor, can I make a new ticket for this problem?

Thanks in advance!

July 28, 2020 at 2:53 pm #6693715

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Actually you don't need to replicate your entire website with all the plugins, the purposes here is just to replicate the issue using a minimal setup so I can escalate this issue to our compatibility team. Then, the only required thing is:

1 - Create a simple Oxygen template, add a translation for it and attach it to a page.
2 - Translate the page and attach the translated Oxygen template for the translated page.
3 - Test it logged in and logged out.

Did you try these steps? In any case I think I was able to solve the issue in your website with these steps:

1 - I clicked to edit the french page where the Oxygen template was being showed in english (hidden link)

2 - Then, I manually adjusted the page to show the correct template from the 'Render page using template option at the page editing screen (see attached screenshot).

3 - Now, I am able to see the exact same template when logged in or logged out at: hidden link

As regarding:

We also have a problem with the Gutenberg editor, can I make a new ticket for this problem?

Please, open up another ticket for that, we are only able to deal with one ticket per issue. Let me know if it helps to solve your issue, have a nice day.

customer_screen_105.png