This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I am using WooCommerce and trying to view the Shop (Chinese) >> Page 2. It does not show any products on the page.

Solution:
I have fixed the Chinese shop Page 2, it is working fine now: http://dev2018.naturesbounty.com.hk/%E5%95%86%E5%BA%97/page/2/?lang=zh-hant

1. I have added this code in wp-config file to increase Max Execution time and WP Memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

set_time_limit(90);

2. And I changed the permalink settings as "Post name" this is optimal & recommended settings. You can find these under WP Dashboard >> Settings >> Permalinks page.

3. Please clear your browser cache and plugin cache too, then recheck the page.

This topic contains 11 replies, has 2 voices.

Last updated by tyroneC 11 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
October 25, 2018 at 10:32 am #2849438

tyroneC

I am trying to view the Shop (Chinese) in page 2

Link to a page where the issue can be seen: hidden link

I expected to see: the product from 17-28

Instead, I got: nothing, a blank page

October 26, 2018 at 3:41 pm #2853594

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have checked the page link you have provided and I can see the issue. You need to follow below steps in order to isolate and solve this issue:

1. You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions, also update WooCommerce Multilingual plugin. You can download it from your account: https://wpml.org/account/downloads/

2. I have noticed that your website’s WP Memory Limit is 128MB. The WP memory limit needs to be increased, it's different than php memory:

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

3. I see that you are using old version of Storefront theme. Please backup your database and site, then update theme to the latest version v2.3.5 - https://woocommerce.com/my-account/downloads/

4. If issue still exists, Please enable WP Debug mode in your site and let me know if any error is shown.
To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_DISPLAY', true );

For more details:
https://wpml.org/documentation/support/debugging-wpml/

Thank you

October 26, 2018 at 5:02 pm #2853792

tyroneC

Hi Noman,

Thank you for reply, after I upgraded all plugin, the problem still happens, pls help.

October 26, 2018 at 5:17 pm #2853880

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

What about Step 2, 3 and 4? Please also follow those steps and let me know the results and I will be happy to check further. If you are unable to do any of those let me know.

Thanks

October 26, 2018 at 5:28 pm #2853913

tyroneC

all completed, pls help

October 29, 2018 at 4:37 am #2856881

tyroneC

Hi, may I know if any update on my issues, the website will launch on 1 NOV, please help to fix, many thanks.

October 29, 2018 at 8:10 am #2857066

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

October 30, 2018 at 1:42 pm #2862044

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Just wanted to update you that I am still working on your site. I made some updates, but I cannot see any php errors in the site at moment. Your site is working quite slow at my end. I am going to test check for plugin and theme conflicts now and will update you asap.

Thanks

October 30, 2018 at 2:54 pm #2862293

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have fixed the Chinese shop Page 2, it is working fine now, please see attached screenshot and link: hidden link

1. I have added this code in wp-config file to increase Max Execution time and WP Memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

set_time_limit(90);

2. And I changed the permalink settings as "Post name" this is optimal & recommended settings. You can find these under WP Dashboard >> Settings >> Permalinks page.

Thank you

October 31, 2018 at 2:15 am #2864092

tyroneC

Thank you, the Chinese shop page fixed, but I found English shop page ALL products missing now when I am checking.

October 31, 2018 at 8:07 am #2864665

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have visited your site and checked shop page in both languages but here both are working fine as you can see in attached screenshots. Could you please clear your browser cache and take another look on it.

Thank you

October 31, 2018 at 8:09 am #2864693

tyroneC

My issue is resolved now. Thank you!