This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 12 replies, has 2 voices.

Last updated by Rohan Sadanandan 1 month, 1 week ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
August 20, 2019 at 3:40 pm #4425137

lilachA

Tell us what you are trying to do?
I'm trying to translate pages as usual, but in some of the cases I get within the translation tool a page builder that does not belong to this page. It belongs to one of the previous pages I've translated.
The result is that I cannot use the translation tool for the new pages' translations.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
capsule-la.com

August 21, 2019 at 7:45 am #4428629

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for contacting WPML Support.

From the screenshot you've shared, it shows that there is a page builder content on the page you are translating.

Could you please check another page & confirm whether the same page builder exists for that page also?

Also, from the debug information I can see that the WP Memory limit is 40MB.
At least 128 MB is required for WPML: https://wpml.org/home/minimum-requirements/
Please add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy publishing. */

Thanks,
Rohan

August 24, 2019 at 1:23 pm #4451789

lilachA

Thank you.
I've changed the memory to 256M, as suggested.

Regarding the duplicate page builders - it happens in some of the pages and not all of them. What happens is that there is a duplicate page builder of the same number that the correct page is, but with the wrong content.
For example, if I'm in page 1599 - I'll have 2 page builders numbered 1599. The first is a wrong one that automatically shows in translation the text shown in page 1598 (instead of 1599) and another page builder numbered 1599 with the relevant boxes that need to be translated.
The thing is, that even if I update all the translations in the correct (the 2nd) page builder, and leave the 1st, wrong page builder with only a dot so I can save the translation as 100% complete - the result is that the translated page shows only the wrong page builder and not the correct, 2nd one.

August 26, 2019 at 10:26 am #4457635

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Can you please disable all plugins that are unrelated to WPML and switch to one of the default themes e.g. Twenty Fifteen, Do you see the same issue?

NOTE:
Also, make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Thanks,
Rohan

August 29, 2019 at 7:50 pm #4483351

lilachA

ok. So I did it, and the pages that already have the translation tool - still have these additional, problematic page builder.
Is there a way to completely delete the translation tool created for specific pages (and only for specific pages) and then re-create them? maybe this will solve the problem?

Also - I believe it might be related to pages that I've used elementor on them, then changed them back to the regular word-press editor and then created the translation through the automatic tool. it is as if the elementor part of one of the previous pages is still working behind the scenes.

How can this be fixed?

August 29, 2019 at 8:17 pm #4483479

lilachA

I've also found the following error codes in some of the pages:
Warning: mysqli_real_escape_string(): Couldn't fetch mysqli in /home/****/public_html/*****/*****/wp-db.php on line 1172

this error repeat itself, each time for a different line.

August 29, 2019 at 8:35 pm #4483503

lilachA

These errors occur once I use manual translation, without the WPML automatic translation tool

August 30, 2019 at 8:23 am #4485263

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.
Instructions to send private information are here: hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Also, please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

Thanks,
Rohan

September 2, 2019 at 10:07 am #4496051

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for sharing the details.
I am checking your site.
I'll update you soon.

Also could you please share the links of some of the pages having the issue so that I directly check it more faster?

For better support, we handle one issue per ticket. So for the memberpress issue, may I kindly ask you to open a new ticket for the same?

Thanks,
Rohan

September 3, 2019 at 11:59 am #4504143

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I'm not able to download the duplicator package which seems to be happening due to the blocking by the security plugin.

Could you please allow me to disable the iThemes Security plugin for some time or if you could disable the same for some time then also it will be fine.

Thanks,
Rohan

September 4, 2019 at 3:44 pm #4512583

lilachA

Hi,

You can disable this itheme for a couple of hours if needed in staging1 (the link I sent you).

Here are examples of pages that showed this problem (they all were elementor and turned to regular wordpress editing:

hidden link
hidden link

September 5, 2019 at 6:11 pm #4521435

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission.
I've downloaded the package.
I will update you soon.

Thanks,
Rohan

September 6, 2019 at 3:20 pm #4526235

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I just checked the page & the found out that the page builder field is coming from elementor.

To remove the page builder field,
1. Navigate to Pages & click on edit
2. Once the editor is loaded click on "Edit with Elementor".
3. This will open the page in Elementor & you will be able to see the field there.
4. Just select & delete the field & save the page & exit to WordPress editor.
5. Now open the translation editor & you will not see that field there.

Thanks,
Rohan