This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Andreas W. 3 weeks, 2 days ago.

Assigned support staff: Andreas W..

Author Posts
September 10, 2019 at 9:51 pm

tiborA

I am trying to: translate this page hidden link into Romanian. But the page design created with the page builder is not kept in the translated version: hidden link

What should I do?
When I edit the page directly it doesn't show the blocks. If I try to do the same with the home page, my design is kept unchanged...and the blocks appear on the Romanian version.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link

A second problem is that in the Romanian language I can't see the products anymore. It shows up blank. And when I want to see a product directly, I receive the message: Oops! That page can»t be found. The translation exists in the back-end.

I hope you can help me out with these two issues.

Thanks!

September 11, 2019 at 4:09 pm #4555199

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

For the about us page, it was necessary to set make a small change in the Multilingual Content Setup of the page at the bottom of the page editor.

Here I set the custom field "panels_data" to copy. This field is related to the Site Origin Page Builder options and will make sure that WPML copies those settings to the translation. I then retranslated the page and the layout is correct now.

For the issue with the shop page and products it might be that we are handling with a compatibility issue.
First of all make sure that all your plugins are updated and revise if the issue still exists.

If the issue is still there disable any additional plugin that is not WooCommerce or related to WPML and its add-ons.

If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

September 11, 2019 at 5:10 pm #4555423

tiborA

Hi Andreas,

Thanks for looking into my problems. For the second one I will follow your suggestions and I will get back to you. The problem appeared after I updated the plugins which are part of WPML. Before that the products were showing in the second language as well.

For the contact page (not about :D) the layout looks good. However it's not translating. There is this page which is marked as the translation of the original page: hidden link (which is the correct one).

...and then there is another one, which I am redirected to if I want to edit the translation. But the content of that page links to this page: hidden link
That's not updating either. It's strange why I have two pages, because under Dashboard -> Pages I only have one Contact page.

By update I refer to the text on the left. The form is OK.
Can you have a look please? I'm confused. Or maybe just reset the translation for this page and start again? How can I do that?

September 12, 2019 at 12:42 am #4556867

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The issue with the translation is that the Site Origin Page Builder does not support our WPML Translation Editors.

In order to translate the pages, you will need to follow the steps in this documentation and then translate manually using the native WordPress page editor.

https://wpml.org/documentation/plugins-compatibility/using-wpml-siteorigin/

Let me know if you do have any questions and give me an update about the products as soon you can.

Kind regards
Andreas

September 16, 2019 at 5:33 pm #4582961

tiborA

Hello Andreas,

Do be honest, I don't understand this compatibility issue. The home page is translated using the same way in which I try to translate the Contact page. The problem is that we have a translation which I've created, and one that you've created. And none of them are actually translating. I was asking if there is a way to delete both of them....and create a new one from scratch. Maybe this is the problem.

Also, if I use the solution provided in your link, it will only apply to the Contact page, or on the website overall?

For the products bug...is there a solution to revert to the previous version of WPML plugins? This issue appeared after I did the update. Before that it was working just fine, so there is no problem with the theme or other installed plugins. From my logic the problem needed to be there also before.

Thank you!

September 16, 2019 at 8:05 pm #4583749

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am really sorry about the confusion. I did not work with Site Origin earlier, so I was not aware about that it has some exceptions.

I recommend that you use the instructions provided in the documentation of the last message.

SiteOrigin will not function completely if translated with the WPML Translation Editor.

1) I have again set the custom field panels_data to Don't translate, as otherwise the translation will not be working when translating manually.

2) I have installed the Duplicate Page plugin to create a copy of the Contact Us page.

3) This page was translated following the instructions from our documentation. Make sure to duplicate, then switch the language to Romanian, click "Overwrite from Original" and then click "Translate Independently".

4) Now edit the page elements and make sure to select the language Romanian for each element inside of its options.

5) For the contanct form make sure to edit the ID for the respective Romanian form.

Use the same translation method for all pages. Let me know if you do have any further questions here or if something does not work out as epxected.

Already created translations can be deleted. In case it will not be necessary to maybe restore those pages also make sure to delete them from the "trash" folder.

The issue with the products has been recreated on new WordPress install and is escalated to our compatilbity team. We will need to invesitgate further and I will contact you as soon I receive a workaround or more details in regards to a fix.

If you wish to downgrade WPML to a earlier version you can find those version by going to https://wpml.org/account/downloads/ and clicking the changelog symbol for each plugin. Anyhow, it is not advisable to run different versions of our plugins.

I would advise you instead to downgrade SitePressOrigin to an earlier version to see if this solves the issue.

Please install

Kind regards
Andreas

September 17, 2019 at 1:27 pm #4588819

tiborA

Hi Andreas,

I will wait until your compatibility team is finished their testing, and after the conclusions I will continue development. I already see some changes, so there is no point interfering with their work.
For example the products now appear on the second language, but they disappeared in the main languae (English). Let me know when you have updates, please.

Tibor

September 17, 2019 at 4:38 pm #4590217

tiborA

Later edit. Maybe it helps your team.

I've repeated all steps on a staging environment from scratch. Updated all plugins, site origin also. After that I took the WPML plugins in order and updated them.

After I've updated WPML Translation Management from version 2.8.6.2 to 2.8.7 the problem with not showing the products appeared. So the setup in which the product page is not redirecting to a 404 is the one from the attachment.

Again, this is happening on a staging version. Not on the live version, which you have access to.

Thanks,
Tibor

September 17, 2019 at 7:31 pm #4590789

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We are sorry about the inconvenience and the compatibilty has been informed.

For now, I would advise you to donwgrade Translation Management to version 2.8.6.2 and even downgrade CMS Multilingual and String Translation in case you receive any notifications or errors.

I will be in contact as soon I receive feedback or a possible workaround.

Kind regards
Andreas

September 19, 2019 at 9:29 pm #4608327

tiborA

Hi Andreas,

So, I've followed your advice and downgraded all WPML plugins. Now the website is working as it should. Products appear again on both languages. I will also solve the problem with the Contact page adding a new page..and working on that. Hopefully it works.

Please don't do any changes without me knowing first on the live version. This will be used by my client. From what I know you have a mirror site using ours. I also have a staging version...we can do tests on that. Please let me know when you have a solution..and when I can upgrade WPML again.

Thanks,
Tibor

September 20, 2019 at 3:23 am #4609461

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello Tibor,

Thank you for your message.

Our compatilbity team provided a fix for the issue.

Could you please provide access to the staging site in oder to test the fix on your environment?
I have enabled the private reply box in order to provide access.

Kind regards
Andreas

September 23, 2019 at 7:47 pm
September 24, 2019 at 12:23 am #4626897

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

We actually just released a new version of our plugins that do cover the fix for 404 errors on SiteOrigin.

Please make sure to proceed with the updates and let me know if this solved the issue.

Kind regards
Andreas

September 25, 2019 at 7:56 am #4636521

tiborA

Hi Andreas,

I've updated the plugins on the live website. It looks like the problem with the 404 errors is solved now. However, I receive the following message:

WPML Update is Incomplete

You are running updated sitepress-multilingual-cms, wpml-media-translation, wpml-sticky-links, wpml-string-translation and wpml-translation-management, but the following components are not updated:

woocommerce-multilingual

...which is strange, because I have the latest version, 4.6.7, installed. See screenshot with the latest versions. Also the Wocommerce multilingual tab is not displaying. So I can't edit the items same as before. Is there a compatibility issue with the beta versions? Am I using the wrong versions?

All the above information can be found on the LIVE version. The staging version (which you updated) works fine.

Thanks,
Tibor

September 25, 2019 at 2:21 pm #4639873

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

When using the Beta please also make sure to install the Beta for WooCommerce Multilingual. On your screenshot, I can see you been using the latest stable version instead.

There are Betas for Woocommerce Multilingual and Yoast SEO Multilingual more down on the page:
https://wpml.org/account/downloads/

I have connected myself to your site which is now using our latest stable versions. Those versions should solve the issue with SiteOrigin and other page builders causing 404 errors. Also editing and translating products worked as expected.

Let me know if you do have any further questions.

Kind regards
Andreas