This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I have bought an elementor page builder plugin but the template isnt the same than the original one, in the translated version

Solution: I this case I would like to ask you to follow this steps for each page you see that has the same issue: - Edit the page -> Go to the Multilingual Section below the body of the page -> Click on 'Show systems fields' link -> Make sure all the custom fields are set to the same state as the 'About' page or the 'Test' page -> Save the changes -> Make a small change in the content of the page using the Divi builder -> Save the changes -> Update the translations.

I also recommend you to manually change the language in the admin menu -> Click 'Edit anyway' button and select the right options in the right column for the layout.

Relevant Documentation:

This topic contains 24 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 1, 2019 at 11:32 am #4118475

melissaK-2

Tell us what you are trying to do?

I have bought an elementor page builder plugin
but the template isnt the same than the original one, in the translated version

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?

July 1, 2019 at 11:39 am #4118537

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to visit this link where you will find our official documentation on this subject and the steps to follow in order to translate Elementor using WPML: https://wpml.org/documentation/plugins-compatibility/elementor/

Kind regards,
Carlos

July 1, 2019 at 1:16 pm #4119273

melissaK-2

Sorry but I am using Dawnthemes woocommerce page builder. Not elementor pro to edit the shop pages, so it's different. That's why the templates change from one language to another, but nothing to do with elementor, but rather dawnthemes page builder. How can I keep the same page builder template with translation integrated?

July 1, 2019 at 1:27 pm #4119383

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

Usually with page builders, there is a custom field that holds the information of the page template and that custom fields must be set as 'Copy' to pass the same information to the translation.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

July 1, 2019 at 2:32 pm #4120203

melissaK-2

I cant find my FTP info

July 1, 2019 at 2:35 pm #4120357

melissaK-2

I have found it please can u send again privacy form? thank you 🙂

July 1, 2019 at 4:21 pm #4121139

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Yes 🙂
I just set your next answer private again.

Regards,
Carlos

July 2, 2019 at 11:32 am #4126373

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I set some systems fields to 'copy' and it seems that the issue disappears in newly created pages. I created a test page titled 'Test' where you can see that in both languages the layout if fullwidth.

In this case I would like to ask you to re-create the About page and let me know if the issue persists.

Regards,
Carlos

July 2, 2019 at 12:06 pm #4126561

melissaK-2

thank you for your help.
Indeed the about page works well now. But the issue remains with the homepage and account page.

There is like a margin on the homepage which isnt supposed to be there
and same issue than about page with the account page.

Thank you for your help

MK

July 2, 2019 at 12:32 pm #4126887

melissaK-2

Same problem for the checkout process:

July 2, 2019 at 12:40 pm #4127005

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi MK,
Thank you very much for your feedback.

I this case I would like to ask you to follow this steps for each page you see that has the same issue:
- Edit the page -> Go to the Multilingual Section below the body of the page -> Click on 'Show systems fields' link -> Make sure all the custom fields are set to the same state as the 'About' page or the 'Test' page -> Save the changes -> Make a small change in the content of the page using the Divi builder -> Save the changes -> Update the translations.

The steps above should refresh the entries of this pages in the database and update the values for the custom fields.

Could you confirm that the issue is solved?
Regards,
Carlos

July 2, 2019 at 1:42 pm #4127441

melissaK-2

It's not possible
the test and account page have different custom fields.

They dont have one single similar fields. What can I do?

Sorry about that and thank you for your help.

Best regards,

Melissa Kerr

July 2, 2019 at 4:36 pm #4128791

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Melissa,
Thank you for your feedback.

In this case the fastest way to solve the issue is by manually translating the page. To do this you just need to edit the page in the default language -> Switch the admin language in the admin menu at the top -> Click on the 'Edit anyways' button -> re-create the translation manually -> Save the changes.

Could you confirm that this way the issue is solved?

Regards,
Carlos

July 3, 2019 at 7:39 am #4132633

melissaK-2

Sorry I really dont understand what you mean...

Best regards,

Melissa Kerr

July 3, 2019 at 7:41 am #4132639

melissaK-2

It seems like the homepage is fixed, but the problem remains with woocommerce translated version and account page.

How can I change this manually?

Thank you