This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Bruno Kos 3 weeks, 2 days ago.

Assigned support staff: Bruno Kos.

Author Posts
June 14, 2019 at 7:07 pm

dominicG-5

I'm trying to see propreties in frenc and in english.

hidden link
hidden link

Doesn't showing up = 404

Why ?

June 15, 2019 at 7:43 am #4025747

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you have a look now? I have translated the slug into "properties", resaved permalinks and cleared the cache and both seems to be opening for me now.
hidden link
hidden link

Regards,
Bruno Kos

June 15, 2019 at 12:46 pm #4027279

dominicG-5

Hi Bruno,

When I test your changes the first time it works ! But I change the french menu, a bit (just add a sub menu to RECHERCHER... And after that... the same problem come again...

I also add a new propreties, from the english interface... and this propretie is showed on the map... but broken link: hidden link

It's weird because some time it works and sometime it doesn't ...

When I traducted the string in WPML, there are some duplicated string... and weird numeric string...

All the Advanced Custom Fields Multilingual... seem to be corrupted... 🙁

Thanks

Dominic

June 17, 2019 at 9:43 am #4034061

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

When I test your changes the first time it works ! But I change the french menu, a bit (just add a sub menu to RECHERCHER... And after that... the same problem come again...

Can you tell me if I am allowed to test this myself on this website? In other words, this would mean that if I add a new menu item ( let me know if there are other ways to reproduce his issue) and create new property and translate it, will it not work again? Or no other properties - previously created - will not work either?

Regards,
Bruno Kos

June 17, 2019 at 12:56 pm #4035357

dominicG-5

Hi Bruno, yes you can do anythings you want. Each time we add a new propretie... the problem come out... Try to created news propreties, both in french and english and translated... the problem will come out . Try to go on propreties from the map, and Search in top menu...

Also, I would like to be add a propretie in french, and a created a automatic translate in english, to be sure than the english user be able too see all propretie.

Thanks Bruno !

Dominic

June 17, 2019 at 1:42 pm #4035719

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi Dominic,

I have created the following properties:
hidden link
hidden link,

But they don't seem to be returning 404 error and I have not done any other change on the site - I simply logged in and only created these properties. Could there be something else triggering 404? I have access the website and created them using incognito mode, so no caching.

I have not resaved permalinks or anything else.

Regards,
Bruno Kos

June 17, 2019 at 2:53 pm #4036355

dominicG-5

Hi Bruno,

On this page the propreties doesn't appear: hidden link

On these pages I see only one propretie diplayed: hidden link and hidden link

Thanks

Dominic

June 18, 2019 at 1:08 am #4039055

dominicG-5

Hi Bruno,

When I'm on this page hidden link and I select ( I press ) search in the side bar... I found this 404 page...
hidden link

On the first page in the header, when I press SEE RESULTS yellow button at right... I found hidden link

There are many pages like that...

Why ?

Thanks...

Dominic

June 18, 2019 at 6:27 am #4040665

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am getting quite inconclusive results, especially when I am logged into the site and not and while using chrome incognito mode, etc. Have a look - some of these links you sent me work, while others don't.

Therefore, can you install your theme here?

WordPress
One Click Login:hidden link
Identifiant :demo
Mot de passe :P3zYqOgn06O2

SFTP Credentials
Server:w5.wpsandbox.pro
Identifiant :wicked-mouse
Mot de passe :CCQoxpUg4e4bhSPO2rO40285
Port:2222

And set it up the same way you did on your site? This is our sandbox testing site where we test various themes and plugins for possible compatibility issues, while we also do this to exclude server issues.

You don't have to clone your whole website - just set the theme in the same way, set search pages ( or any other pages theme requires) and try to create 2-3 properties translated into other languages.

Let me know if you need any assistance or more information!

Regards,
Bruno Kos

June 18, 2019 at 12:42 pm #4043871

dominicG-5

Yes it's done

Login: hidden link
Username: demo
Password: P3zYqOgn06O2

Yes ! it's done, I try one propretie but it looks like bugging again..

Thanks

d.

June 18, 2019 at 2:20 pm #4044397

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've tried various properties and they seem to be linking correctly:
hidden link
hidden link

They don't seem to be returning 404, at least in my case. The next think I have tested is the following:

hidden link
hidden link

And I clicked "See results" button - None of these pages return 404 for me. Can you show me the page ( or set of pages) that return 404? I'd like to check myself and send as much information we can gather to our compatibility team in Case we find the pattern of nonworking pages.

Regards,
Bruno Kos

June 18, 2019 at 2:44 pm #4044501

dominicG-5

Hi Bruno,

On the demo, the problem, is the propreties are not display on the map... but is a google demo.. so... I had a bug on demo, but now I don't remember what I did...

To tell the true, is very hard to me, because Reatyspace was supposed to work very well with WPML... and now... nothing woorks well... I tried to desactived all plugins.. but it bug again...

What's the other user of RealtySpace and WPML have did to solve this kind of problem ?

Thanks

Dominic

June 18, 2019 at 2:50 pm #4044567

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I can imagine that it can be frustrating for things not working as they should. Here are some of the links with various issues clients had with Realtyspace - these are only few and I don't see any of them being related with what you're having here:

https://wpml.org/forums/topic/issues-with-translating-slugs-of-the-realtyspace-theme/
https://wpml.org/forums/topic/issues-with-translating-realtyspace-theme-url/

I would really like to bring this to our compatibility team, but so far the results we're having are very inconclusive and yet I don't know what to send to them for testing (since as I explained in my previous reply, all those links worked).

It will really help me if you could the following:
- send me the URLs with 404
- perhaps even images
- steps on how to reproduce

Any information you think that me and compatibility team could benefit from while investigating this issue more deeply.

Regards,
Bruno Kos

June 18, 2019 at 3:08 pm #4044699

dominicG-5

Yes, so ... When I'm in the ENGLISH demo, and I clic directly on yellow button SEE RESULTS, why I'm redirect on the french part of the site... It should be stay on english part. No ?

June 18, 2019 at 3:17 pm #4044749

dominicG-5

Ok it's probably because the page is not traduct... 😉 So... if the demo run well... what can I do ? To solve the hidden link problems...