Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 1 month, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
February 24, 2021 at 8:36 pm #8167403

hugov-2

I have two issues with my translation:

1 the switcher on homepage doesn't work, the link is hidden link which goes back to hidden link (englisch version) the correct link should be hidden link if type that in directly it goes to the correct page

2 all pages translated just fine except 1, if I click on the + it starts a new page instead of translating the English one.

February 25, 2021 at 7:52 pm #8175961

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Regarding the redirect, I am not able to crawl this URL for any active redirects however it looks like this is a custom redirect rather than caused by WPML.

if possible review your .htaccess file and any active redirect plugins.

For the page translation issue, what are your results if you try the following:

1. Install a plugin such as duplicate post
2. Go to pages and duplicate this page
3. Now try to add a translation to the new page

Let me know your results, please.

February 28, 2021 at 9:32 am #8189861

hugov-2

Hi Bobby,

1 I updated the htaccess it works a bit better, the translation links redirect to mysite.eu/nl but the dutch homepage is on mysite.eu/nl/homepage. How do I fix the links?

2 I duplicated the page but shows the same problem, open a new page instead of starting the translation.

Thanks

March 1, 2021 at 6:38 pm #8200835

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed It is necessary to take FULL BACKUP of your database and your website. Providing us with access, you agree that a backup has been taken **

I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

March 2, 2021 at 12:22 am #8202099

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details!

If possible, please review them as I am not able to access the wp-admin area.

March 2, 2021 at 7:27 pm #8211685

hugov-2

Hi Bobby, did you check it? I still have the same errors.

March 3, 2021 at 4:53 am #8213387

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details!

Please go to your profile->edit profile and enable "display hidden languages"

Then go to Pages and click on "+" for me the Automatic Translation Editor opens as expected and I am able to add the translation.

March 3, 2021 at 11:59 am #8217023

hugov-2

I tried that both with my own account as the one I provided you and still it starts a new page instead of starting the translation. All the other pages translated just fine, just this specific page (which has no special content just text and images) won't translate.

Did you also check the my other issue:
1 the switcher on homepage doesn't work, the link is hidden link which goes back to hidden link (englisch version) the correct link should be hidden link if type that in directly it goes to the correct page

March 3, 2021 at 5:50 pm #8221137

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Yes I can see the issue on the homepage, how are you currently setting your homepage?

It looks like you are using some sort of redirection?

To set a static homepage go to Settings->Reading and set it to static, then set your homepage as the static homepage.

Right now, your homepage is set to latest posts which is your blog and then the URL hidden link is being redirected which does not seem correct and causes this issue.

Regarding the page that is not translating, which is the exact page that is experiencing this issue?

March 3, 2021 at 7:20 pm #8221579

hugov-2

Thanks Bobby that solved the redirect issue.

It is the -products- page that won't translate. All other pages work fine.

March 4, 2021 at 6:49 pm #8231155

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

On products page for Dutch I was able to click on "+" and create a translation that is connected and with German I test "duplicate", which seems to have worked ok as well.