This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by arnoldS-2 4 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 19, 2019 at 6:38 pm #3842329

arnoldS-2

Please visit this page:

hidden link and also any product for example; hidden link

Receiving following error;

Warning: Invalid argument supplied for foreach() in /home/arnoldszmerlings/public_html/myecard.co/wp-content/plugins/woocommerce-multilingual/compatibility/class-wcml-product-addons.php on line 191

May 20, 2019 at 8:19 am #3844705

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you have a staging site available perhaps, where we could try some tests and troubleshooting options?

Regards,
Bruno Kos

May 20, 2019 at 12:04 pm #3846611

arnoldS-2

Thanks Bruno

I cloned it for you here;

hidden link

May 20, 2019 at 1:45 pm #3847499

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you install Duplicator plugin and create a package so that I can try this on my localhost and possibly escalate further to 2nd tier?

https://wpml.org/faq/provide-supporters-copy-site/

And provide me credentials for hidden link, so that I could download packages? If yes, I will need WordPress admin username and password so I could download those packages. I have marked your next reply private so you can safely add this information.

Regards,
Bruno Kos

May 21, 2019 at 11:05 am #3854569

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I was able to create a Duplicator package (using Pro version). I activated only the following plugins (see image), so this could be related to some of the plugins and we need to see which one.

Therefore, on your staging site, can you see if this works properly only with those plugins and if yes, start activating one plugin at a time so that we can see which one triggers this. Let me know and I will try my localhost then.

Regards,
Bruno Kos

May 24, 2019 at 6:58 am #3881667

arnoldS-2

Hello Bruno

As I suspected there is an issue with WPML multicurrency. This is the second webite within as many weeks I have had to deactivate the interface. I have deactivated WPML on ALL of my websites and am using hidden link instead without any issues.

I guess you never had activated multicurrency in your staging site?

I look forward to your thoughts.

Thank you

May 24, 2019 at 9:13 am #3882807

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I guess you never had activated multicurrency in your staging site?

According to my image, you can see that it has been activated, I did not make any change in relation to this, but the problem seems to be coming from elsewhere (potentially a conflict with some other plugin) because I left only few core plugins active, the issue has gone. Can you grant me access to hidden link once again?

I am trying to access it, but I get 403 - Forbidden - Access to this resource on the server is denied!

Regards,
Bruno Kos

May 24, 2019 at 12:28 pm #3884681

arnoldS-2

Hi Bruno

I have attached a screen grab of the setting I am referring to. When I un-ticked and deactivated multi-currency mode; the issue disappeared.

He is the link to the orginal (now working) site with all the plugins active and WPML multi-currency mode deactivated.
hidden link

hidden link

hidden link

The multi-currency engine that is working is located here;

hidden link

Do you now understand what I am referring to?

Thanks

May 24, 2019 at 1:14 pm #3885059

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I know exactly what setting you are referring to :). However, in my case (on my localhost test) it was still enabled and the site working, but with minimal setup.

Can you grant me access to hidden link once again? I'd like to check this once again on my localhost (need to download packages once again), I will check if I indeed missed something here or why are we getting different results.

Regards,
Bruno Kos

May 30, 2019 at 11:45 am #3922739

arnoldS-2

My issue is resolved now. Thank you!