This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 8, 2019 at 8:35 am #3764603

stevenC-7

I am trying to:

I have 4 pages that I translated. The pages of the default language are giving a internal server error 500, while the translated pages are accessible.
swimcap.upgraders.be/contact gives internal server error 500 while swimcap.upgraders.be/en/contact is working fine...

Interesting is that the pages are visible in preview (contact page, blog, etc...), but not when I publish them.

It seems the pages of the default language are showing an internal server error 500.
What is causing this and how can I fix it?

Thanks!

May 8, 2019 at 9:43 am #3765101

Dennis

Hi,

Welcome to WPML Support forum.

Internal server errors are usually triggered by php errors. Could you please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

/*enable debugging*/
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false);

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Try to reproduce the issue.

Locate the debug log in: /wp-content/debug.log using FTP, then edit/view the content of the file. Can you see php errors related to WPML? It would be great if you can share with me the debug.log content using pastebin.com

Additionally, could you please try to deactivate all non-related WPML plugins, switch theme to TwentySixteen, does the issue still persist or not?

NOTE:
+ Please backup your site completely before doing this test.

Kind regards,
Dennis

May 8, 2019 at 10:13 am #3765371

stevenC-7

Fatal error: Uncaught InvalidArgumentException: Translation name cannot be empty in /home/public_html/swimcap/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php:107 Stack trace: #0 /home/public_html/swimcap/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php(44): WPML_ST_Page_Translation->validate_values('134097', '', 'woocommerce-che...') #1 /home/public_html/swimcap/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php(107): WPML_ST_Page_Translation->__construct('134097', '', 'woocommerce-che...', '', false, '') #2 [internal function]: WPML_ST_Page_Translations_Persist->create_translation_from_db_record(Array) #3 /home/public_html/swimcap/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translat in /home/public_html/swimcap/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php on line 107

May 9, 2019 at 5:05 am #3773125

Dennis

Hi,

Thank you for your reply.

Could you please try these steps and see if it resolves the issue?

Note: Please make sure to make a complete backup of your site before proceeding.

-delete the strings from String Translation page. Select the strings and then click 'Delete Selected Strings' button

-Go to WPML>>Support page
-Click on Troubleshooting link (link in the middle of the page)
-In Troubleshooting page, please click on the following options of 'Clean up' section. Wait for confirmation of processing after each one.
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
-Recreate ST DB cache tables

Please let me know how it goes.

Kind regards,
Dennis

May 9, 2019 at 10:08 am #3774997

stevenC-7

My issue is resolved now. Thank you!