This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 4, 2018 at 3:24 pm

maximilianP-5

Dear Support Team,

I published some new pages and interlinked them on my start site.

All of a sudden one page, that was published and working long time, returns a 404.

hidden link

I updated all plugins etc. I cannot make sense out of this problem as everything has been working fine before.

Your help is higly appreciated :)!

October 5, 2018 at 9:06 pm #2791703

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

It could be that something got corrupted in the database and somehow the English page is missing it's language assignment. I also see that your list of pages show 2 drafts, but when I try to click All Languages on drafts, I don't see any pages. So, let's try this.

Please be sure to make a full backup of your site and database. Then, go to WPML -> Support -> Troubleshooting. Look for 'Clean up' and click the following:

- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

Does this resolve the issue?

October 6, 2018 at 10:01 am #2792707

maximilianP-5

Thank you very much for your suggestions.

I did everything that you recommended. Unfortunately, this did not solve the problem.

October 8, 2018 at 1:14 pm #2796102

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

May I please have permission to install the Adminer plugin so that I can take a closer look at the database? Or, you could send me a copy of your site so that I can test it locally. You could make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

October 8, 2018 at 1:33 pm
October 8, 2018 at 4:33 pm #2796937

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access. I set up a copy of your site locally but I am not able to reproduce the issue. On the test site, I don't get a 404 error. I also found that if you change the page slug, the page loads correctly. I changed it back and it returns 404. So there must be a redirect happening somewhere. If you temporarily deactivate all non WPML plugins and switch to a default theme, does the 404 error still happen? Please be sure to clear the cache and resave permalinks after disabling the plugins.

Please let me know the results of this test.

October 8, 2018 at 9:51 pm #2797449

maximilianP-5

I used Wp-Staging to clone the site to the /staging/ folder. You can try and login with your account.

I disabled all plugins + changed to a standard WordPress theme and flushed the cache. Unfortunately, still no changes.

October 9, 2018 at 1:26 pm #2800150

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for setting up the staging site. I disabled WPML plugin on the staging site and the link still redirects to a 404 error. Unfortunately, if the issue is not related to WPML, it is out of the scope of our support policy to provide support.

Did you see that the link works correctly on the live site with WPML deactivated?

October 9, 2018 at 1:32 pm #2800171

maximilianP-5

I'd rather prefer NOT to deactivate WPML on my live site, as I am scared that all my settings will be lost!

I also do not really see that there is a server side redirect going on. However, I am pretty much clueless on what I can do next. This error occured after publishing several translated articles on my website that had nothing to do with the affected page.

I cannot believe that this is due to any other plugins. I have the suspicion that some database error is there due to something in the WPML plugin, which is not automatically recoevered by just deactivating it.

Any deeper analysis / (paid?) support that you can recommend?

October 9, 2018 at 2:30 pm #2800472

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Are you able to see on the staging site that the URL is still redirecting to a 404 page when WPML is disabled?

I created a local copy of your site and the page does not redirect to 404 with OR without WPML activated. Could you perhaps ask your hosting provider to check the server logs to see if there are any errors showing up there? Unfortunately, if I can't isolate WPML as the cause of the issue, I really don't have further troubleshooting options. I really wish I could provide a solution for you.

I did run a quick search on your database for the URL. I see lots of returns in the yoast_seo_links table. Some of these show a target_post_id of zero. I'm not sure if this could be the cause of it, but perhaps you could try deleting these in the staging version of your site and see if this resolves the issue?

We don't have an option for paid support, but I can suggest if you need further assistance you consider contacting one of our certified partners from this link: http://wpml.org/documentation/support/wpml-contractors/