Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
The client was experiencing issues with automatic translation not functioning properly on their website.
Solution:
We recommended the following steps to resolve the issue:
1. Navigate to WPML > Settings.
2. Under Translation Mode, switch to 'Translate What You Choose'.
3. In the Translation Editor section, select 'Editor for new translations: Classic Translation Editor', then save and reload the page.
4. Switch back to 'Advanced Translation Editor' and set Translation Mode to 'Translate Everything Automatically'.
After performing these steps, changes to the page content should be translated automatically.

Please note that this solution might not be relevant if it's outdated or not applicable to your case. If the issue persists, we highly recommend checking the related known issues, verifying the version of the permanent fix, and confirming that you have installed the latest versions of themes and plugins. If you still need assistance, please open a new support ticket.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Long Nguyen 2 months, 3 weeks ago.

Assisted by: Long Nguyen.

Author Posts
February 26, 2024 at 1:41 pm

canA-7

Hi 🙂 The page hidden link is set to "Translate everything automatically" and "Publish without review". But updates to pages or other content won't automatically update in translations. You still have to go into the pages and manually click update. Credits are not the issue as the page currently has more than enough assigned. Am I missing a setting?

February 26, 2024 at 2:37 pm
February 27, 2024 at 4:26 am #15347095

Long Nguyen
Supporter

Languages: English (English )

Timezone: Asia/Ho_Chi_Minh (GMT+07:00)

Hi there,

Thank you for contacting WPML support, I’m happy to help you with this issue.

It could be a temporary issue. I fixed the issue on your site with the following steps: go to WPML > Settings:
- Translation Mode > Switch to Translate What You Choose.
- Translation Editor > Editor for new translations: Classic Translation Editor > Save and reload the page.
- Switch back Translation Editor: Advanced Translation Editor (recommended) and Translation Mode: Translate Everything Automatically.

Now, after changing the page content and saving it, it is translated automatically.

Looking forward to your reply.
Thanks

February 27, 2024 at 7:51 am #15347494

canA-7

Thank you. It seems to be resolved now 🙂

canA-7 confirmed that the issue was resolved on 2024-02-27 07:51:44.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.