This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by Carlos Rojas 3 days, 11 hours ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 6, 2019 at 12:33 pm

stefanA-12

Hi! 🙂

I am trying to: In the user dashboard the language switcher is set to the second language and in the profile it is choosed a second language too. From my subscription menu I choose to purchase a subscription and then opens the wc cart page. But in this moment the page change always from a second language to the default language.

Link to a page where the issue can be seen: It needs to login in the frontend into the user dashboard. Manage Listings - Subscription - column "Current (10) and there in "View" - click on "Place it in the shopping cart" - Then the cart will change from the second language to the default language, but this is not right!

To understand it more easier, append some screenshots.

I tried to fix that, but can´t find the solution for that! I need your help! 😉

Many thanks in advance,

Stefan

October 7, 2019 at 6:18 pm #4710059

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I applied some troubleshooting steps and I would like to ask you to go to Woocommerce -> Woocommerce Multilingual -> Custom Taxonomies and translate all untranslated terms.

Could you tell me if the issue persists?

Kind regards,
Carlos

October 8, 2019 at 8:42 am #4713263

stefanA-12

Hi Carlos,

thank your for your help! 🙂

Now I have translated all custom taxonomies. But the problem exist still, the page jumps from Spanish language to English language.

How it is possible to fix that?

Kind regards, Stefan

October 8, 2019 at 12:29 pm #4715157

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Stefan,
Thank you very much for your feedback.

If you deactivate the Cloudflare service, does the issue persists?

Regards,
Carlos

October 8, 2019 at 2:14 pm #4716311

stefanA-12

Hi Carlos,

now I have disabled the OPcache and also the CDN.

Both features are now deactivated, but the issue still happens. 🙂

Please, have a look to that against.

Thank you, Stefan

October 9, 2019 at 10:15 am #4721665

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Stefan,
Thank you very much for your feedback.

I applied several troubleshooting steps again and now automatically language switching disappeared, however I can't reproduce the exact same steps because my user can't see/add-to-cart the subscriptions. Could you double check this?

Regards,
Carlos

October 9, 2019 at 10:51 am #4721929

stefanA-12

Hi Carlos,

for me it seems to be the same as before, a second language is switching to the default language to English.

To reproduce that I can recommend following:

Please do in the login button a registration with the user role Agency, so it is possible to buy a subscription.

Go in the dashboard to profile and change the language to Spanish.

Change in the toolbar the language switcher to Spanish too.

Click on anuncios in the dashboard and then on suscripción.

Now click on ver and click on añadir al carrito de compra.

Now you will see the site with the cart is changed to the default language to English.

This is the error, it should be in Spanish.

For further questions I am at your disposal.

Reg., Stefan

October 9, 2019 at 12:09 pm #4722541

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Stefan,

Could you provide credentials to access as an Agency? I have set your next answer private.

Regards,
Carlos

October 9, 2019 at 1:51 pm
October 9, 2019 at 3:16 pm #4723969

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
I think I have found the cause of the issue.

Please follow this steps:
- Go to WPML -> Settings -> Post Type translations -> Set 'Subscripciones (subscription)' to the option in the first column (Traducible - solo mostrar los elementos traducidos) -> Save the changes.
- Go to Subscriptions -> Edit one -> Duplicate it to Spanish -> Save the changes.

At this point the only thing that you need to make sure is the URL of the 'Add to cart' button points to the product in the correct language, because right now is pointing to the ID of a product in English, and if this keeps pointing to the product in English, then you will still get redirected to the cart in English.

Could you tell me the results of the steps above?

Regards,
Carlos

October 9, 2019 at 5:45 pm #4724963

stefanA-12

Hi Carlos,

I have changed the option in the Post Type Translations and there is now a feature with possibility to add slugs. Append a screenshot to that.

You wrote: - Go to Subscriptions -> Edit one -> Duplicate it to Spanish -> Save the changes.

You mean I should edit a WC subscription product? In the products is not the feature how is it in the page, I mean to duplicate a complete page to a other language.

Sorry, what I should do now? 😉

Thank´s for your help,

St.

October 10, 2019 at 8:48 am #4728495

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Stefan,

In this case you need to add a different slug for each language and save the changes. The next step will be to translate or duplicate a subscription and double check if the issue persists.

Please let me know if you need my assistance to apply this steps, and I will be more than happy to help you.

Regards,
Carlos

October 10, 2019 at 9:35 am #4728811

stefanA-12

Hello,

I have added the slugs, a screenshot for that append.

Then I have changed something in the WC product (subscription): Third Party Campaign 30 Days

I have done the translations in the second languages.

But the issue to change to the English language in the cart is still available. 🙁

What I can do now? 😉

Reg., St.

October 10, 2019 at 11:09 am #4729695

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Stefan,

I would like to ask your authorization to make all the changes and run more tests in the site in order to save time and try to find a solution sooner. Before you give me your authorization I need to ask you to confirm you have a full backup of the site in case we need to restore it.

Looking forward to your message.
Regards,
Carlos

October 10, 2019 at 11:45 am #4729867

stefanA-12

Hi Carlos,

just I have done a new full backup.

Good idea, if you want to solve that issue on my site to save more time and to finish it finally! 🙂

Now it´s your turn! 😉

Reg., Stefan