Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 23 replies, has 3 voices.

Last updated by martineG-3 4 years, 3 months ago.

Assigned support staff: Francesco Di Candia.

Author Posts
September 22, 2017 at 9:45 am #1380144

martineG-3

Hello,

When making changes in the WPML translations from NL to FR or EN on our main homepage the saving icon stays visible. It seems that it cannot finish the operation after making changes.

At first I don't receive an error message.
I have to exit the page and afterwards the changes seem to be made, but jscript errors appear. What could be the cause of this?

Thanks in advance
Tony

hidden link

September 22, 2017 at 12:40 pm #1380352

martineG-3

Edit: the page keeps on saving.

Saving never stops. Here is some extra info.
Maybe the requirements are not enough.
BTW. WordPress and all WPML plugins are up-to-date.

<I>Info
PHP

Version 5.6.30-0+deb8u1
Memory limit 128M
Memory usage 18.52 MB
Max execution time 0
Max input vars 2500
Multibyte String extension Loaded
SimpleXML extension Loaded
WordPress

Version 4.8.2
Multisite No
Memory limit 128M
Max memory limit 128M
</I>

The problem right now is that the website in engelish and french are not displaying properly.
Not all translations are visible.

Thanks in advance for helping me out.

September 25, 2017 at 1:38 am #1381548

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi @martineg-3,

Thank you for contacting WPML support. I'd be happy to help you on this.

It seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

To help you further on this issue, I would need further information, so could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

I look forward to your reply.

Thanks

September 25, 2017 at 8:01 am #1381718

martineG-3

Hello Shekhar,

Thanks for looking into it.
I'm still having problems locating the issue.
Therefore I enclosed the debug information.
Maybe it will make things clear for you.

Thanks in advance.
Tony

September 26, 2017 at 2:54 am #1382974

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Could you also share the feedbacks of the following tests with me?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

September 26, 2017 at 8:35 am #1383161

martineG-3

Hello,

I followed the steps you suggested.
I changed the wp-config.php to make debug.logs possible, but with no effect.
The log file won't appear. Maybe it is because the action of saving the page cannot complete its task.

In the backend of WPML all translations are made, but it the frontend they're only partly visible. Other fields remain in dutch, altough they have been translated to english and french in the backend.

Look forward to your reply.
Thanks
Tony

September 27, 2017 at 2:48 am #1384330

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site on our local server for testing.

Look forward to your reply.

Thanks

September 28, 2017 at 9:28 am #1385925

martineG-3

Hello
You can find the credentials in the PM.
Thanks

September 29, 2017 at 3:05 am #1386794

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

I recently tried to save a page and I can save the page without any issues, so could you please check the issue once again.

Also, could you please create a new page and test the issue on your end?

Look forward to your reply.

Thanks

September 29, 2017 at 6:32 pm #1387569

martineG-3

Hi,

Thanks for looking into it, but the problem only appears on the homepage.
So when translating to english or french the saving icon keeps busy running.

Other pages do save and finish the action.
Because the hompage can't finish the action not all translations are visible in the frontend although they are listed in the backend.

Tony

October 2, 2017 at 4:32 pm #1389207

Francesco Di Candia

Hi Martine,
this is Francesco from WPML Customer Service. Since Shekhar will be off for today, I'll help you, I hope this is ok for you.
I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

❌ Before proceeding please make a full database and website backup! ❌

- Update all WPML plugins & WordPress core.
- Disable all plugins except WPML related
- Temporarily change the theme to a default WordPress such as TwentyFifteen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.
Let me know which plugin creates the problem,
thank you, Francesco

October 3, 2017 at 10:02 am #1389855

martineG-3

Hello Francesco,

Thanks for your support.
I'm trying to locate the problem.
The saving problem is only on the main page (homepage).
The NL (dutch) version completes the saving, but when trying to update the WPML trnaslations, the saving doesn't seem te finish.

In the Chrome developers tool in the french version i get following error report:

Uncaught SyntaxError: Unexpected token <
at new Function (<anonymous>)
at Object.success (?lang=fr:674)
at i (jquery.js:2)
at Object.fireWith [as resolveWith] (jquery.js:2)
at y (jquery.js:4)
at XMLHttpRequest.c (jquery.js:4)
(anonymous) @ ?lang=fr:674
i @ jquery.js:2
fireWith @ jquery.js:2
y @ jquery.js:4
c @ jquery.js:4
XMLHttpRequest.send (async)
send @ jquery.js:4
ajax @ jquery.js:4
n.(anonymous function) @ jquery.js:4
(anonymous) @ ?lang=fr:673
i @ jquery.js:2
fireWith @ jquery.js:2
ready @ jquery.js:2
K @ jquery.js:2

In the english version i get:

VM322:2 Uncaught SyntaxError: Unexpected token <
at new Function (<anonymous>)
at Object.success (?lang=en:676)
at i (jquery.js:2)
at Object.fireWith [as resolveWith] (jquery.js:2)
at y (jquery.js:4)
at XMLHttpRequest.c (jquery.js:4)
(anonymous) @ ?lang=en:676
i @ jquery.js:2
fireWith @ jquery.js:2
y @ jquery.js:4
c @ jquery.js:4
XMLHttpRequest.send (async)
send @ jquery.js:4
ajax @ jquery.js:4
n.(anonymous function) @ jquery.js:4
(anonymous) @ ?lang=en:675
i @ jquery.js:2
fireWith @ jquery.js:2
ready @ jquery.js:2
K @ jquery.js:2

Does this help a bit to solve the problem?
Tony

October 4, 2017 at 5:32 pm #1391604

Francesco Di Candia

Hi Tony,
I've turned off some unnecessary plugins and I've modified and saved the BUREAU text in homepage.
As you can see there is a fake EN and FR text just before the real text in EN and FR page.
Can you try please to update and save now the homepage?
Keep me informed, thank you.
Francesco

October 5, 2017 at 9:01 am #1392160

martineG-3

Hello Francesco.

You've really saved the day! Page is saving fine now.

Although I'm not really sure what you mean with:
As you can see there is a fake EN and FR text just before the real text in EN and FR page.
On the dutch page there is a ditty news ticker scrolling. This is translated with WPML to english and french. But, the english and french ticker is not showing. Could that be the fake text?

Also, you have deactivated some unnecessary plugins. Is it best to delete those completety from the list, since they might slow down the website?
What was the cause of the homepage not saving. Which plugin could have been the troublemaker?

Hope to hear from you.
Thanks for helping me with this.
Tony

October 5, 2017 at 10:43 am #1392332

Francesco Di Candia

Hi Tony,
sorry for the misunderstanding but with fake EN and FR text I was speaking about some 'EN' and 'FR' positioned by me in EN and FR pages, just to check if everything was fine saving. Now I see that you've modified the text in correct languages.
About the ticker, can you check if it was working before?
Regarding the plugin, should be better to deactivate and delete all the unnecessary plugin because they make heavy the site and, if not updated, can be sources of attempts of malicious intrusions.
Please let me know if this resolves your issue or if you still need help.
Thank you, Francesco