This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Pages translation links to category page

Solution: The issue was happening as category slug and page slug was same and client was using category strip function from Yoast. So to fix the issue: - Change page or category slug and make it unique once. - Disable Category strip https://kb.yoast.com/kb/how-to-remove-the-categories-prefix/

This topic contains 5 replies, has 2 voices.

Last updated by Shekhar Bhandari 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 20, 2019 at 6:05 am #4056767

robinW-7

Hi Shehar Bhandari,

We discussed the broken pages yesterday, here's the google drive link of the site backup:
hidden link

Kindly check it and help me to solve the issue please.

Thank you.

June 20, 2019 at 6:11 am #4056827

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

It seems the permission is not granted so I have asked for permission, could you please provide me the drive permission to download the file.

Look forward to your reply.

Thanks

June 20, 2019 at 6:51 am #4057047

robinW-7

Hi, I've passed the permission, kindly check the details now.
Thank you.

June 20, 2019 at 11:15 am #4059311

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The issue is happening due to a conflict between a page slug and category slug, you have a page which slug is blogs and it should display as hidden link in the same time you have a post category with same slug "blogs" which in default displays as hidden link.

But you are using YOAST SEO settings to strip the category off from the URL so the same URL becomes hidden link and creates conflicts leading to the problem, the same is for videos.

So to fix the issue you should either perform one of the steps:
- Change page or category slug and make it unique once.
- Disable Category strip hidden link

Let me know if this helps.

Thanks.

June 21, 2019 at 1:43 am #4063729

robinW-7

Hi there,

Thank you, these pages are fixed by the following steps:
- Change the category slugs and make it unique once.
- Reconnect the pages with the post categories.

But I'm confused why this issue only happens to the translated pages?

Could you please tell me why so I can avoid these issues in the future?

Thank you again.

June 21, 2019 at 2:58 am #4064163

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

As I already mentioned the two slugs were matching so on default language it was showing category page instead of the actual page which looked like it's working properly. On the other end, the category wasn't stripped so the page wasn't working properly.

Let me know if this helps.

Thanks