Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: 404 Error - Posts or Pages are not found in second language.

Solution: A 404 errors in most cases can be solved by going to Settings -> Permalinks and simply applying the "Save" button.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by butterandflyB 1 year, 2 months ago.

Assigned support staff: Andreas W..

Author Posts
May 17, 2019 at 10:04 pm


Hi team,
Since today in the afternoon, my website is fine in the main language: English but when I change to Portuguese if I click in the categories (any country), the page is not found.
I'm not sure why is this happening. I've clear the WPML cache, but still not working.

hidden link

Could you please help me in solving that?
Thank you very much

May 17, 2019 at 10:42 pm #3837237

Andreas W.

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)


Thank you for your message.

It seems the 404 errors were solved after going to Settings -> Permalinks and simply applying the "Save" button.

Please let me know if you spot out further issues.

Kind regards

May 18, 2019 at 12:04 pm #3838877


My issue is resolved now. Thank you!

June 23, 2020 at 9:49 am #6433309


Hi team,
I still have the same issue. Every time I need to go to setting and press save on permalink.
Is there a permanent solution for that issue?
I need to go to check everyday otherwise people click on the category and the page is not found. Many thanks

June 23, 2020 at 10:16 am #6433453


I've spoken to one of your colleagues about 2 weeks ago via chat and she gave me some instructions, however I cannot find it to explain what I've done to you.