If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by paula-beatrizL 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
July 2, 2019 at 10:00 pm #4130175

paula-beatrizL

Tell us what you are trying to do?
I've followed most of the solutions for the "page not found" problem and nothing worked so far.
When I'm logged in my site I can see the "flag buttons" options to switch from Spanish to English and the translations are ok. But when I go to a different browser or a hidden window I can see only the Spanish flag and the translated pages are not found.
Is there any documentation that you are following?
Yes, I've followed different solution in this forums for the "no page found" problem
I don't want to have a fixed page for people to choose the language before access my site, I want them to get the main page in Spanish (original language) and choose the English version if they want to.
For example this page westriveracademy.com that use this plugin
What is the link to your site?
hidden link
hidden link

July 2, 2019 at 10:15 pm #4130211

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Could it be the case that those pages have not yet been translated to 100% percent?

If you are sure that they are completely translated please go to Settings -> Permalinks and simply click the "Save" button.
Verify if this solved the issue.

If it did not go to WPML -> Settings -> How to translate Posts or Pages and make sure that the Classic Translation Editor or the Advanced Translation Editor is activated. Then go again to Pages and translate them. The WPML Translation Editors do provide an overview about each string available.

Make sure that any page is translated to 100% when translated for the first time, otherwise will not show up.

I hope this will solve the issue. Otherwise, let me know I will have alook at your site.

Kind regards
Andreas

July 2, 2019 at 10:42 pm #4130315

paula-beatrizL

Hi, thanks for the quick response Andreas, but the problem still persists. I have the classic editor enable and the page is translated at 100% what I see is that the URL hidden link redirects to hidden link and then I get the page not found.
In the permanent link, I have chosen Post name so I don't know why I'm being redirected to a plain kind of URL. And I don't understand why when logged in I do get everything ok but not as a visitor.

July 2, 2019 at 10:49 pm #4130323

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Please try to change the URL site structure to "language in directories". You find this option on the top section of WPML -> Languages.

Then go to Settings -> Permalinks and choose a "pretty link" which stands for any slug that more complex than "plain" or "post name". Try to choose "Date & Name" or something similar. Then save the permalinks.

Does this solve the issue?

Kind regards
Andreas

July 2, 2019 at 11:59 pm #4130555

paula-beatrizL

HI! great the problem seems to be solved but I don't know why the home page and the one I give you as an example, still are redirecting to a not found page which is quite strange.

July 3, 2019 at 12:05 am #4130603

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

July 3, 2019 at 12:41 am #4130671

paula-beatrizL

My issue is resolved now. Thank you!