Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 5 days, 18 hours ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
June 23, 2020 at 1:38 pm #6435409

butterandflyB

Hi team,
I'm having an issue for over a year with the WPML.
I use English as my primary language. However, in the second language (Portuguese), when I click on categories, it shows "Page not Found".

It happens every week, and I need to go to WordPress settings - permalink and click save and then it all goes back to work.

But I need a permanent solution. I cannot go to categories every day to check if the links are not broken.

About 3 weeks ago I've chatted with one of your colleague and she told me to change somethings on the htaccess file. But I can't find the ticket to tell you what I've done so far, to try and fix it.

Is it possible to help me? Many thanks

June 24, 2020 at 8:23 pm #6447717

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It really hard to debug an issue when it happens in a intermitent way, also it is not something we receive reports of something happening in other websites. Here I would need to look at the content of your .htaccess file itself and also it would prefereable if we had some pattern on how to replicate the issue, the possible actions that causes it, such as:

1 - Theme/Plugins update;
2 - New post creation;
3 - New category/tag creationg;

We could also migrate your website to a test server and try to replicate the issue there as well as we could also have some sort of server incompatibility in your case. Another thing I would recommend would be a test category creation, translation and then we could monitor it for the issue replication. So, in this case, please, try to provide these details:

1 - Your current .htaccess file content;
2 - The possible specific actions that could trigger this issue (theme/plugins update, post creation, etc);
3 - If the issue happens when you create a new category and translate it. This can determine if it only happens for your existing categories.

Please, let me know, the next reply is marked as private in case you need to provide sensitive information such as .htaccess file content, WordPress Dashboard and FTP access details and so on. Thank you for your collaboration and patience, have a nice day.

July 7, 2020 at 7:15 pm #6542143

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Oi, tudo bem sim, obrigado 🙂

As related to your issue, the provided access details are not from an user with administrator permissions, I would need some admin access in order to experiment with settings and so on. In any case, I realized it won't help at this moment, for now, I would ask you to proceed as the following:

1 - Browse to your wp-config.php file and enter the lines of code below:

define('WP_DEBUG', true);
define('WP_DEBUG_LOG', true);
define('WP_DEBUG_DISPLAY', false);

2 - Monitor the issue and pay attention to when it is happen.

3 - When the issue is replicated, please, go to your hosted wp-content/uploads folder and provide me with contents of the 'debug.log' file.

Please, make sure to provide the 20 latest lines here, additionally you can upload the debug.log to any file sharing host, such as Dropbox, Google Drive, etc and send me the url for download.

See: https://wpml.org/documentation/support/debugging-wpml/

It will help us to log any possible related issue to this random issue and this way to provide us with some more details of its cause. Thank you for your collaboration, have a nice day.

July 9, 2020 at 2:23 pm #6559383

butterandflyB

Oi Marcos,
I didn't have time to change the wp-config.php, however, I was going to do now, but before I did, I realised that I'm having the issue right now.
I've changed the admin access, so you can have a look.
Here is the Dropbox link for the debug.log: hidden link

July 9, 2020 at 6:21 pm #6562009

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details. Unfortunately the debug log info doesn't provide us with any meaningful error message about what could be happening, again I wasn't able to replicate the issue, as per our new support policies we are unable to proceed with our support efforts for something we are not able to replicate, even so, I would like to point you in a possible direction.

1 - You have the the category base slug removed as a setting in your WordPress Dashboard > SEO > Search Appearance > Taxonomies > Category URLs and it could conflict in some way with your WordPress installation.

2 - As an alternative I would recommend you to use this plugin https://wordpress.org/plugins/no-category-base-wpml/ to achieve the same functionality. Just make sure if you are going to use this plugin, you should set the Yoast SEO option back to keep the category base slug.

Hope it helps to fix your issue and achieve your desired results, have a nice day.

July 10, 2020 at 4:01 pm #6570587

butterandflyB

Hi Marcos,
I've a look at my wp-config file and I already have the code that you mentioned inserted:
define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );
define( 'WP_MEMORY_LIMIT', '256M' );

You've mentioned that you could migrate my website to a test server and try to replicate the issue, as you could see yesterday.
I needed to go to permalink and press save, to make the translation work again.
So definitely it is an issue with WPML.

You also said that I should try and change WordPress Dashboard > SEO > Search Appearance > Taxonomies > Category URLs
However, will that not change my permalinks and therefore all my pages will be not found?

As I mentioned to you, the issue happens every week, but I don't know the day or when is going to happen. As you said you cannot continue to help me as you can't replicate the issue...I guess if you could migrate and check it, you could see what is happening.
Many thanks

July 10, 2020 at 7:39 pm #6571383

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my previous private reply and let me know when the migration process is done. Thanks.

July 16, 2020 at 2:25 pm #6613985

butterandflyB

Hi Marcos,
I'm trying to do the migration, however, I keep receiving this message:

Error! The URL specified is incorrect. Please check if your account is configured with hidden link

July 16, 2020 at 11:37 pm #6616425

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please make sure the 'hidden link' part of the url is not missing, you can enter the full url in this format: hidden link. Please, let me know if it works this time, have a nice day.

July 23, 2020 at 11:40 am #6660901

butterandflyB

Oi Marcos,
I've migrated but received a message that it failed.
Could you check if is that the case and let me know so I can try again.
Thanks

July 24, 2020 at 10:39 am #6670423

butterandflyB

Hi Marcos, I've tried the migration process again today and it worked.
Also, I would like to point it out that today I have the issue again. This time, the English language had the problem and most pages were not found.
The only ones that worked, were for example, if I click "England" category, instead of showing all posts, it showed a post that the title starts with the word "england".
To make it work again, I had to go to settings - permalinks and press save.
I hope you can replicate the issue again.

July 24, 2020 at 4:40 pm #6672727

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the udpates. Does the issue happened in your test server? Please, try to replicate the issue in our test server, then if it happens, please update it here and we'll check that. The debug mode is turned on in the test server, so we can track the issue in case it is replicated there. Thank you for your collaboration, have a nice day.

July 30, 2020 at 10:43 am #6706773

butterandflyB

Hi Marcos, unfortunately I cannot replicate the issue, because as I've mentioned before, it happens almost every week, with no apparent reason.

July 30, 2020 at 8:10 pm #6711415

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case I recommend you to try a new host or refer to your host support for further help. I really wanted to be able to help you and I really sorry for not being able to do so.

As per our support policies (see https://wpml.org/purchase/support-policy/) we are not able to provide support for an issue which we can't replicate, it happens because in most cases you could have a server compatibility issue, your issue is not something reported by other customers, so we can't determine WPML is the culprit here. I hope you find a definitive solution for your issue, have a nice day.

August 5, 2020 at 2:30 pm #6741697

butterandflyB

Hi Marcos,
I understand what you are saying, however, it is very disappointing that, the issue is related with WPML and the policies doesn't allow you to help me figure it out.

I have the issue right now, and it happens when I started to translate my posts. I will leave the site not working, so you can have a look, as I'm not able to replicate it when I want, if I press the permalink save button.
I hope we can sort it out this time,
Many thanks