Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 28 replies, has 4 voices.

Last updated by sarah.n 5 years, 7 months ago.

Assigned support staff: Andrey.

Author Posts
June 6, 2014 at 9:06 am #414383

patrykK

Any progress on this? ... your immediate assistance would be greatly appreciated as Google is de-indexing the pages ...

June 6, 2014 at 11:50 am #414495

Denise

Hi,

I'm currently working with a developer on this. I will get back to you as soon as we figure out what can be done. It seems as though English was your site's original default language. During that time your theme which defines the custom post Pressemitteilungen and gives it the slug unternehmen/presse was activated. Although your default language is now German, English is still seen as your original language. If English was seen as your secondary language you would be able to rename the English slug to "company/press" through WPML without an issue.

I am looking into a way to define German as the original language throughout your site. There may be no way to do this without editing the database which I would not recommend on a live site. I will let you know what solutions I find today so that we can solve the slug naming issue.

The fact that you can't see the English Press pages is another issue. Although your English Press pages have German slugs, I am able to see them without any problems. I am not experiencing any 404 notices when accessing those pages as shown in the screenshot above. Have you tried accessing these pages from another browser or computer?

Thanks,
Denise

June 6, 2014 at 6:45 pm #414772

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear patrykK,

Denise passed this thread to me, hope this is OK.

I will take a look and update you here as soon as I know more. Did you try Denise's suggestion ?
_

With Regards

Andrey

June 10, 2014 at 8:50 am #416035

patrykK

What suggestion? ... about viewing the English pages? .. that's not the problem. I can see the English pages with German slugs. I was referring to not being able to see the English pages with English slugs - which is the problem your dev is looking into.

Speaking of which, is there any news from your dev on this?

June 10, 2014 at 3:30 pm #416367

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear patrykK,

Let me check this, soon I get back to you.
_

With Regards

Andrey

June 11, 2014 at 1:07 pm #417096

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear patrykK,

Could you provide me some examples of the pages that produce 404 error ?
_

With Regards

Andrey

June 11, 2014 at 1:53 pm #417167

patrykK

hidden link

hidden link

hidden link

June 12, 2014 at 8:55 am #417581

patrykK

Any progress on this? … it has been 9 days since i first reported the issue and it's becoming quite frustrating

June 13, 2014 at 10:43 am #418417

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Hello Patryk,

This is Sarah here. Andrey is unavailable today so I am taking care of the support tickets in his queue.

I am reading through the comments in this ticket as I write this. I am also logged in on your site (you provided access details for it which are attached to this ticket) trying to understand what is happening.

I will get back to you as soon as I know more.

June 13, 2014 at 11:12 am #418432

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

As promised here I am again 🙂

Looking through your "Translation options" I have noticed that you have enabled "Translate custom posts slugs (via WPML String Translation). ": wp-admin/admin.php?page=sitepress-multilingual-cms/menu/translation-options.php

However the actual setting for "Use different slugs in different languages for xxx. " for the different custom post types you have enabled is not active.

Furthermore, when you do activate it, WPML reads and prints the original slug in German rather than in English!

I believe the problem starts from there. Please see the 3 attached screenshots below that show the points mentioned above.

My question to you is, are the cpts registered by your theme or a plugin?

I am currently downloading your theme to check for myself but if the cpt is coming from your theme and you happen to know which theme file handles the cpt registration it will save me some time searching for the code.

June 13, 2014 at 11:41 am #418453

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

I'm back again 🙂

So I believe I managed to correct it. Check this out: hidden link

I am not getting a 404 not found any longer. Can you please confirm this also on your end?

This is what I did:

1. First I disabled the "Translate custom posts slugs" option: wp-admin/admin.php?page=sitepress-multilingual-cms/menu/translation-options.php

2. From the String Translation admin screen I searched specifically for the English slug "company/press"

I had 1 result come up registered under the context "theme softgardentheme". I then deleted it.

2. Next I searched specifically for the German slug: "unternehmen/presse"
I again had 1 result, this time under the context "WordPress". I deleted this also.

3. Went back to: wp-admin/admin.php?page=sitepress-multilingual-cms/menu/translation-options.php and enabled the "Translate custom posts slugs" option.

4. Scrolled down to the cpt "Pressemitteilungen" and enabled "Use different slugs in different languages". This time the original English slug was shown correctly in English.

5. I proceeded to translate the slug to German right there on that screen.

I attach screenshots below showing the above 5 steps using the "White Paper" cpt as an example.

Would you like to try it with your remaining cpts? Let me know if you prefer that I do it for you. I'll be happy to assist.

P.S You will want to save your permalinks after step 5 above.

June 16, 2014 at 1:04 pm #419637

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear patrykK,

Please follow Sarah's words.

_

With Regards

Andrey

June 24, 2014 at 8:21 am #424084

patrykK

THANK YOU SARAH, YOU ARE THE BEST!!

(Apologies for not responding last week but i was too overwhelmed with excitement)

June 24, 2014 at 10:46 am #424201

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

🙂 You are most welcome! 🙂
Glad it works well now again.