This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Jessica 1 year, 4 months ago.

Assigned support staff: Yvette.

Author Posts
May 20, 2018 at 9:55 pm #2198167

Jessica

I am trying to: translate the subtitles on the products

Link to a page where the issue can be seen: hidden link / see screenshots in backend

I expected to see: the subtitle form field on the english translation

Instead, I got: not field to enter the translation

I'm using the AVADA theme

May 22, 2018 at 3:47 pm #2209913

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

If the element is not appearing in the Translation Editor, it means it is not recognised and should be added via the :

WPML - > Translaiton Management -> Custom XML Configuration

I can help you with that.

1. Temporary Access to your system
Could you please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem? The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

2. Include a sample product/page that I can test with.

Thanks

May 24, 2018 at 7:18 pm #2225190

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Curiously, you already have all the settings reuiqred to translate this field. You can, in fact, do this in the Pink site:
Example: hidden link

However, the same settings on the "yourveda" site do not seem to have any effect. This may be due to a different configuration in the theme or set of plugins installed.

Do you see this?

May 29, 2018 at 8:40 pm #2248267

Jessica

Hello Yvette

I just looked at a translation of a product on pink.ch and yourveda.ch, but I can't find any difference. To me both sites don't allow the translation of subtitles.

Just to make sure, that's the part I want to translate: see screenshot

May 30, 2018 at 9:50 am #2249980

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Appologies - I was looking at the wrong field. Thanks for the clarification.

May 30, 2018 at 5:30 pm #2252715

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I am able to translate the subittle on the product :
hidden link

by setting the tranlsation options to "transalte" for custom field "pyre_page_title_custom_subheader" in : WPML -> Translation Management -> Multilingual Content Setup -> Custom Fields transaltion

Does this resolve your issue? You should now make the same changes in your other sites.

May 31, 2018 at 6:58 pm #2258195

Jessica

Thank you. That's exactly what I was looking for!

Best wishes

Jessi