This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Bigul 12 months ago.

Assigned support staff: Bigul.

Author Posts
September 5, 2018 at 7:54 pm

daniloD-6

Dear support,

My pages are not leading to the translation when languages are switching, but only on mobile version. On desktop it works fine.

I added a screen shoot where you can see what link is generated to another language.
On screen shoot you can see that active page is /listings/premium-projects, but on Polish version the links leads to /action/na-sprzedaz (you can see front the link selected in blue).

How to fix this?

September 6, 2018 at 12:39 pm #2710705

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Languages and choose *Store a language cookie to support language filtering for AJAX * option of *Language filtering for AJAX operations*. Then make sure you are still having the issues or not.

If you are still having the issues, maybe it will be happening because of the older version of WP Residence theme. So please upgrade to the latest version after a full site backup and check the issue is existing or not. Check this link for more details - hidden link

--
Thanks!

Bigul

September 6, 2018 at 4:52 pm #2711759

daniloD-6

Dear Bigul,

Thank you for your reply, but unfortunately it did not solve my problem.
Theme is updated to the latest version.

Please see screen shoots that I sent you for better understanding my issue.

September 7, 2018 at 8:33 am #2713795

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can reproduce the issue. The issue is also happening when minimizing Desktop browsers. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page
2) Click on Troubleshooting link (blue link in the middle of the page)
3) In Troubleshooting page, please click on the following options of *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Assign translation status to duplicated content
- Fix post type assignment

Maybe you are facing this issue because of compatibility conflicts. So to make sure if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to the WP Residence parent theme or WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate the plugin one by one to see with which one there is an interaction issue

--
Thanks!

Bigul

September 8, 2018 at 6:53 am #2716578

daniloD-6

Nothing worked,

I have tried everything.

September 8, 2018 at 4:31 pm #2717074

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. Now I am not able to login to your site because of the following error. Please check.

ERROR: The Google Authenticator code is incorrect or has expired.

It requires further debugging. So please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

September 10, 2018 at 2:31 pm
September 10, 2018 at 2:41 pm #2720348

daniloD-6

I am not sure if you received my message, so I am writting again.

Authentificator is now disabled.

Duplicator is creating backup every night so you can download it.

Thanks

September 10, 2018 at 5:57 pm #2720998

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please upgrade your PHP version to 5.6(the recommended version for WordPress) or greater if possible for a better performance of the site. Check the attached images for more details.

I made a Duplicator copy of your site now. Will debug further and get back to you as soon as possible. Please wait.

Please note, I have installed Duplicator free version on your site because the Pro was showing a Memory error.

--
Thanks!

Bigul

September 11, 2018 at 2:41 pm #2724277

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the bug is existing on my local copies after the initial debugging procedures. Therefore I have forwarded the details to our second tier team for the expert opinion and waiting for their feedback now. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 11, 2018 at 2:48 pm #2724301

daniloD-6

Thank you

September 14, 2018 at 9:13 am #2734705

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the issue is existing on our local copies after the primary investigation procedures. Maybe it will be happening because of some compatibility conflicts.

Therefore I have escalated the ticket to our second tier team for further debugging. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

September 26, 2018 at 2:52 pm #2767760
anna

Hi Bigul

I know the person in charge of communicating my replies to you is on vacation. So I will write here.

I cannot replicate what you describe on our test area with wpml. I want to send you the credentials in private to check. Please let me know how I can do that.

Thank you

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-page-switching-between-lanuages/

September 28, 2018 at 1:38 pm #2774085

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @anna,

I have created a ticket for your issue. Because it sounds like a different one. Please check the following link and let me know your feedback.

https://wpml.org/forums/topic/split-page-switching-between-lanuages/

--
Thanks!

Bigul

October 17, 2018 at 1:43 pm #2824766

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, our team has traced the theme code which is having the compatibility issues for Mobile Language Switcher. We have updated the theme author about this.

We are expecting the fix will be included in the future version of the theme. But right now we don't have an exact date or timeframe required for the fix. May you can check about this with the theme support. Thank you for the understanding.

--
Thanks!

Bigul