Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 5 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 23, 2019 at 5:09 pm #3878193

rafav

I am trying to: Make the english version of this page to save the changes in the html, images and path: hidden link , however, every time I save the page, changes go away.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link

What I´ve tried so far: Deactivate all plugins (except wpml related), change theme to twnety nineteen, resolve all html errors within the block = no result.

May 23, 2019 at 7:20 pm #3878999

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 24, 2019 at 8:25 pm #3887455

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Please, try the following:

1 - Make sure your server enviroment meets our minimum requirements. I noticed the memory limit for WordPress is defined as 40MB in your WordPress Dashboard > WPML > Support menu, while the minimum required is 128MB. See: https://wpml.org/home/minimum-requirements/

2 - Using the default WordPress page/post editor click to edit your translated content and manually adjust the translated html content. See: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/

Please, let me know if it helps to fix your issues. Have a nice day.

May 27, 2019 at 7:54 am #3894287

rafav

Hi there,

I rise the memory limit to 256, but still cannot update the info on the english version of that page. Could you try on your local and see if you are able to discard any bad configuration on my server?

Thanks

May 29, 2019 at 9:11 am #3913755

rafav

Hi there,

Since you seem unable to debug the problem (neither do I) I´ve tried to create a new page and see if changes happen there. It seems in a new page when I create the translation of a spanish and try to save it, it overwrites the original translation, so the only translation it remains is the last one I save. Clearly its a plugin configuration problem, but I´m unable to find the solution.

May 29, 2019 at 3:45 pm #3917073

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

May 30, 2019 at 7:55 am #3921061

rafav

Hi,

That would be a problem, since that plugin requires sftp to be install on the original server, which is not the case, neither could be, for security reasons. That´s why I sent you a link with the files and database the last time. Can you not mount it locally? With xampp its really a few steps.

regards

May 31, 2019 at 8:54 am #3928679

rafav

Hi there,

Any other solution?

regards

May 31, 2019 at 8:43 pm #3933163

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Although it is possible to replicate your website locally using your provided database dump, a migration to cloudways as requested before give us the option to easily debug your website and also to provide our support staff including our second level support the opportunity to debug it if some assistance from them is required without the need to create several separated installs locally.

I couldn't understand the security concerns as the migration process is pretty straigth forward and it is done for support purposes only, also there's no need to install the plugin via SFTP when you have the option to simply install it using your WordPress Dashboard plugins installation interface.

If it is still not possible, please, give duplicator a try so we can have a unified package we can share with our second level support in case we need their assistance, for that, please, consider: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day

June 5, 2019 at 11:04 am #3959745

rafav

Hi there,

Have you been able to replicate the issue?

regards

June 5, 2019 at 6:18 pm #3963363

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and your patience while waiting for a solution. I took a detailed look in your website issue using the duplicator package. Here is how to solve your issue:

1 - In your translated homepage you can remove all the class attribute of your images, so instead of:

 <img src="/wp-content/uploads/2019/01/imprescindible0.jpg" alt="" class="wp-image-115">

You should try:

 <img src="/wp-content/uploads/2019/01/imprescindible0.jpg" alt="">

This is what I tried in your translated homepage and it works as you can see at: hidden link

Please, give it a try and let me know, have a nice day.