This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to translate my website from french to dutch but some elements are missing in the translation.

Solution: I looked the issue and followed this steps: - I edited the page in the original language (French) -> Save it -> Translated the page using Translation Editor -> Re-saved the translation and now the issue seems to be solved.

Relevant Documentation: https://wpml.org/documentation/plugins-compatibility/elementor/

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 5 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 14, 2018 at 7:09 pm

nicolasv-5

I am trying to: translate my website from french to dutch

Link to a page where the issue can be seen: hidden link

I expected to see: See screenshot 1, with text in dutch instead of french

Instead, I got: Screenshot 2

May 15, 2018 at 11:13 pm #2148270

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please visit this link where you will find our official documentation on how to translate sites built with Elementor using WPML: https://wpml.org/documentation/plugins-compatibility/elementor/

Please let me know if you need further assistance.
Kind regards,
Carlos

May 16, 2018 at 12:38 pm #2157070

nicolasv-5

Hi Carlos,

I have already looked at the documentation, and haved previously used WPML. So a general link to the documentation won't help me.
So I need support because there's a bug, and it feels like you didn't even look at my situation before replying.

I completed the translation process, but only images are showing and no text.

Can you please look into it?

May 16, 2018 at 4:13 pm #2161024

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I looked the issue and followed this steps:
- I edited the page in the original language (French) -> Save it -> Translated the page using Translation Editor -> Re-saved the translation and now the issue seems to be solved.

Could you confirm the issue is solved?

Best regards,
Carlos

May 22, 2018 at 3:43 pm #2209894

nicolasv-5

Strange to have to do it twice, but it worked, thanks.

I don't know how that would scale with a bigger website...

May 22, 2018 at 3:46 pm #2209906

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contct us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos