This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by lucieS-2 11 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
October 18, 2018 at 1:19 pm #2828052

lucieS-2

I continue this issue with Otto. He told me to assign it to him

Hi Otto,

Thanks for your reply. I´ll do it
I have one page (home page in Spanish) that I translate into French, clicking the + sign. Everything seems ok and I save the page, but the page doesn´t change the + sign into the pencil...I have tried severla times.
do you know why?
Thanks

October 18, 2018 at 2:26 pm #2828324

lucieS-2

Hi Otto,

it´s the homepage I can´t translate

hidden link

Best

October 18, 2018 at 3:22 pm #2828499

lucieS-2

Also I have some pages in "awaiting for translator" mode. How can I change that? I want to translate it by myself.
Thanks

October 19, 2018 at 8:08 pm #2832980

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

To cancel the "waiting for translator", you can go to WPML -> Translation Management -> Translation Jobs and cancel the existing jobs. Is the homepage one that is waiting for a translator? If so, please cancel the job and then try to translate it.

If not, are you seeing any errors in your browser console when you save the translation? Here is some information about how to view your browser console: hidden link

Lastly, please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Browse to the page with the issue and/or reproduce the issue.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

October 20, 2018 at 2:30 pm #2834305

lucieS-2

Hi Lauren,

The homepage issue is ok now.
I tried to find info but I can´t find any about why I have jobs "waiting for tranlator". What is this? I did not send any translation to anyone. I thought all Woocommerce products were already translated. Are they not?
I am confused about this.
Besides I cannot see how to cancel these jobs. I went where you told me but I do not see the option to cancel the Woocomerce products that say "waiting for translator".
Finally, if I am able to cancel these jobs then the products are not translated? Where do I have to translate them?
Bear in ming that I used the Qtranlate X importer, so I thought all products were already translated.
Thanks a lot,

October 20, 2018 at 11:02 pm #2834684

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 22, 2018 at 5:30 pm #2839221

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending me access to the site. Can you please tell me where you are seeing pages awating translator?

I also looked at the products. In WooCommerce -> WooCommerce Multilingual -> Products, I can see that the translations just need to be marked as completed. If you click on the round icons (in the screenshot), you need to check the box at the bottom "Traducción terminada" and then save the translations.

Please let me know if you need any further assistance and I will be happy to help.

October 22, 2018 at 6:48 pm #2839512

lucieS-2

Hi Lauren,

Thanks for your message.
In this case, I am not talking about the Woocommerce products, I´m talking about the pages.
I attached you an image from WPML / Translation management, that is where I see "awaiting for translator". You can see at the bottom that there is "cojines" that is awaiting for translation and I have 4 or 5 pages in this situation as well.
The thing is that I see that "awaiting for translator" when I choose the Spanish language that is the main language (no need for translation). When I choose the French language, that is the one that needs translation from Spanish, I don´t see "awaiting for translator" and all pages looks ok....Is this normal? Is there something wrong?

When you say, "In WooCommerce -> WooCommerce Multilingual -> Products, I can see that the translations just need to be marked as completed" I see what you mean but ...is there some way to mark all products in bulk as completed or I have to go one by one?
Thanks a lot,

October 22, 2018 at 8:09 pm #2839695

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

For the pages that say "waiting for translator", please go to WPML -> Translation Management -> Translation Jobs. Here you can see some that say waiting for translator. Tick the checkbox next to these and click Cancel Selected. This should resolve the issue.

For the products, you can try going to WooCommerce Multilingual -> Settings and temporarily change to edit translations using the native WooCommerce editor. Then, go to the list of products and use the language switcher at the top of the dashboard to change to French. Then select all products and in the bulk action dropdown, select edit. Then edit one of the products and click Update or Save. This might allow all of the products to be updated at once. If not, then you will need to manually set them as completed.

Please let me know if you need any further assistance and I will be happy to help.

October 22, 2018 at 8:17 pm #2839709

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

For the pages that say "waiting for translator", please go to WPML -> Translation Management -> Translation Jobs. Here you can see some that say waiting for translator. Tick the checkbox next to these and click Cancel Selected. This should resolve the issue.

For the products, you can try going to WooCommerce Multilingual -> Settings and temporarily change to edit translations using the native WooCommerce editor. Then, go to the list of products and use the language switcher at the top of the dashboard to change to French. Then select all products and in the bulk action dropdown, select edit. Then edit one of the products and click Update or Save. This might allow all of the products to be updated at once. If not, then you will need to manually set them as completed.

Please let me know if you need any further assistance and I will be happy to help.

October 26, 2018 at 3:39 pm #2853591

lucieS-2

My issue is resolved now. Thank you!