Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 3 weeks, 5 days ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 24, 2021 at 5:48 pm #8393143

Martin Mart

Page translation not showing on the frontend.

March 24, 2021 at 6:32 pm #8393279

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

March 25, 2021 at 12:32 pm #8399651

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sharing credentials. Did you by any chance change the translation editor during the translation process? Or change the translation mode on different pages? I'm asking because if I view the manual translation mode on the page I don't see any content, but I do see the translations in the translation editor. By manual, I mean if you edit the original page and then use the admin language switcher at the top of the dashboard and change to your secondary language, you can see the page in the native WordPress editor instead of in the WPML translation editor.

March 25, 2021 at 1:11 pm #8399951

Martin Mart

Hi Lauren,

I asked the team, but nobody changed it manually.

March 26, 2021 at 1:43 pm #8408347

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'd like to try a few different ways of translating the content, but I don't want to lose anything on your live site. To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

March 29, 2021 at 12:31 pm #8422431

Martin Mart

Hi Lauren,

I installed the plugin you suggested, but I have no clue how to do a snapshot with all the options you requested.

Is it very impolite to ask you to do it yourself?
Or you can give me a step by step instruction from the web with all the options you need.

Thank you very much.

March 29, 2021 at 9:06 pm #8425731

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to install Duplicator and make a snapshot, so I will deploy the site locally for testing and let you know what I find.

April 2, 2021 at 1:43 pm #8455261

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous private reply and let me know once the migration is complete. Thanks!

April 7, 2021 at 9:30 am #8480549

Martin Mart

Hi Lauren, the migration was also not working. I set up a copy of the site. How can I reply privat?

April 7, 2021 at 3:03 pm #8483989

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have marked the next reply as private and you can share credentials to the test site in the private fields.

April 8, 2021 at 1:52 pm #8493265

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates, Lauren is off today, so, I am taking over this ticket. I took a look at your staging/test website and noticed the page 'Escort Hamburg' was not properly linked to the english version, so, I proceeded with these steps:

1 - I clicked to edit the english page using the standard WordPress post editor, for that, you only need to click to edit the german page, then change to the english version using the top admin bar language switcher.

2 - From the english page editing screen, I clicked to make it a translation of '--None--' from the 'Language' box and saved these changes (see attached screenshot).

3 - Back the german page, I clicked to connect this page with a translation from the 'Language' box, then I chose the english translation and saved the changes as well.

See: https://wpml.org/faq/how-to-link-already-translated-pages/

4 - You can see the results at hidden link by clicking the english flag.

Please, let me know if it helps, have a nice day.

customer_screen_03.png
April 8, 2021 at 2:41 pm #8494027

Martin Mart

Hola Marcos,

On the live side is a completely different behaviour.
Please check yourself.

Also these 2 paged having issues, as you can read above:
hidden link
hidden link

Thank you........ Mart.

Bildschirmfoto 2021-04-08 um 16.32.20.png
Bildschirmfoto 2021-04-08 um 16.29.43.png
April 9, 2021 at 3:24 pm #8503313

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a look at your production website and noticed the page at hidden link is displaying its translation properly when the english language is browsed.

However, at hidden link I still see the content is not being displayed. I ook a look at your WordPress Dashboard and confirmed the translation for 'Escort Aachen' is not being displayed in the content when viweing it using the WordPress default post editor. I recommend you to try the following:

1 - Click to edit the 'Escort Aachen' in the german language, then change to the english language, delete this page and delete it from the trash as well.

2 - Back the the german 'Escort Aachen' page, add another translation for it, you should have your translated setences saved as you added the first translation using WPML Translation Editor.

Sometimes the translated page can get corrupted in the database, for those cases, adding a a new fresh page would help to fix the issue.

Please, let me know if it helps, have a nice day.