This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by Vincenzo 1 year ago.

Assigned support staff: Vincenzo.

Author Posts
September 4, 2018 at 11:02 pm #2704879

decormec-saV

I am trying to: Im trying to get my site translated and when I press the + sign in my spanish version to make it in english the data from my betheme doesnt appear in the new page for me to change it. The translation page gets stuck at 0%

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

September 5, 2018 at 8:55 am #2705961

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- Open Default(Spanish) language page
- Alter original content in some/any manner even you can just add an empty space
- Press Update/publish button
- Now open secondary(English) language page in translation editor and now it will display all fields

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

September 6, 2018 at 7:32 am #2709707

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for the login details. I see you are using Muffin Builder and not a visual composer in your site. You can not use translation editor to translate Muffin Builder content. You need to add translation manually.

Here is doc for more details:
https://wpml.org/documentation/theme-compatibility/create-multilingual-wordpress-websites-using-betheme-and-wpml/#translating-muffin-builder-pages

Thank you

September 12, 2018 at 3:34 am #2726061
decormec-saV

Hi thanks for getting back to me. Ok I managed to do what you said, I still have a few issues.
Before following your steps I pressed the + button to translate a page but the content is empty. How do I delete this translation so I can copy the content in spanish from the muffin builder ?
Now the english version of the page is empty, I press copy content from spanish and nothing happens. I would like to see Translate independently so I can follow same instructions you sent.

Spanish hidden link
English (empty) hidden link

Also I have copied content from one page to the other but some images dont appear. You can see here.
Spanish hidden link
English hidden link

I have 2 menus on my site and when I press the english flag it changes my menu and is empty.
Spanish hidden link
English hidden link

How do I translate menus ? When I go to Menu sincro all the items are green and I cant edit, when I follow the link on the bottom part with instructions I go to a window where I dont see any menu item just code like "Menu Item Label 845"

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/split-menu-problem-in-my-site/

September 12, 2018 at 1:08 pm #2727675

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello,

Ok I will check the translated pages that are empty now. If you have saved the page when its empty then you might need to restore site from backup. I will check further to confirm.

For the menu issue and translating menus I have created a new ticket for this since this is a separate issue. Here is the link to the new ticket: https://wpml.org/forums/topic/split-menu-problem-in-my-site/

Thanks

September 12, 2018 at 1:36 pm #2727718

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

1. I have deleted old translation.
2. Then Duplicated the same page again, all content is copied into translated page.
3. After that I was able to see “Translate independently” button.
4. I changed some text and now translation is working fine:
- hidden link
- hidden link

Please note sliders are not shown on the English page, this is because you need to translate Slides posts (custom post type) as well: hidden link

And then add the translated version on the English page. Because some sliders on this page are being created using Slides >> Category posts. Once slides, slides Category translations will be added, they will be shown on the English page as well. For now you can also test with some sample content and both pages will translate separately.

Thanks

September 17, 2018 at 1:50 am #2739247

decormec-saV

Hi I still have bugs, these images are not sliders they are a gallery and only some of the images appear in the translated page.

Original: hidden link
Translation: hidden link

Same issue happening here for example:
Original: hidden link
Translation: hidden link

Also I cannot duplicate these pages to translate:

hidden link
hidden link

thanks guys, cant believe this is that difficult

September 18, 2018 at 8:29 am #2744022

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

- I have noticed that you are using older version ( 20.9.6 ) of BeTheme theme and latest version of BeTheme theme is 20.9.6.2.1, please update the theme and let me know if this resolves the issue or not.
hidden link

- You are using older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest official release version. Or you can download it from your account: https://wpml.org/account/downloads/

- Please clear all sort of caches in your site plugin cache ( WP Fastest Cache Premium) / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

Please let me know how it goes?

Thank you

September 21, 2018 at 2:11 am #2753661

decormec-saV

Hello this has not helped. I still cannot duplicate hidden link
and hidden link to translate
Also images from an image gallery appear on one page but not the other.

September 21, 2018 at 11:49 am #2755069

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Vincenzo.
Since Noman currently has a few days off, I will replace him here in the forum.
I hope this is OK with you.

This is happening because the translations are already in progress.
To fix this, you can follow these steps:

- Go to WPML -> Translations
- Use the filter to show only the posts that are "Available to translate"
- Search for the one that you wish to Duplicate
- Click on the "Resign" Link
- Go to WPML -> Translation Management
- Search for the post/page that you wish to Duplicate
- Select it
- Select the "Duplicate content" option
- Press the "Duplicate" Button
- Now you can edit the translation to complete it

Please let me know if this solves the issue or if you need further details.

Thank you

October 1, 2018 at 5:21 am #2777154

decormec-saV

Hello I still cannot see image galleries in translated pages for example:

These images are not sliders they are a gallery and only some of the images appear in the translated page.

Original: hidden link
Translation: hidden link

Same issue happening here for example:
Original: hidden link
Translation: hidden link

please help

October 1, 2018 at 2:38 pm #2778525

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

from what I can see in the HTML source, the images come from a different domain. Can you please verify that?

If the images are on the same WordPress install, please go to WPML -> Settings -> Media Translation and "Start" the Media duplication procedure.

Thank you