This thread is resolved. Here is a description of the problem and solution.

Problem: Translated pages are missing the main body content from the original page.

Solution: The client resolved this by deleting pages and creating the news pages with the content

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.28 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by julienF-5 2 years, 2 months ago.

Assigned support staff: Lauren.

Author Posts
April 4, 2018 at 2:57 pm #1565005

julienF-5

Hello Team

I know it's an known issue, I read some thread support regarding this but I don't solved my problem

I am trying to translate the body of page using the translation editor but the body field doesn't appear

Link to a page where the issue can be seen:

I expected to see the body field

Instead, I got nothing

Thx for your Help

Julien

April 5, 2018 at 1:08 pm #1566029

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

First, please go to WPML -> Translation Management and if there is a translation job in process for this page, mark it as complete or cancel it.

Next, please go to Plugins -> Add New and click on the Commercial tab. Click "Check for Updates".

Now, go to the page in the original language. Make any small change and click Update. Now, when you edit your page, do you see the content/body fields available for translation?

If not, please try temporarily switching back to the parent theme and follow these steps again.

Please let me know the results of these tests. Thanks!

April 7, 2018 at 1:08 pm #1568388

julienF-5

Hello Lauren

Thank you for your help

I followed your process and guidelines but unfortunately, it still doesn't work

Thank you for your help

Best regards

Julien

April 9, 2018 at 3:53 pm #1573971

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

April 10, 2018 at 4:53 pm #1584894

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. I believe the body form is not showing because the only content in there is a shortcode, which most likely has not been declared in a wpml-config.xml file. Please see the following documentation which can walk you through how to add custom shortcodes and create a wpml-config file. You can also paste the custom cofig code to WPML -> Translation management -> Custom XML Configuration. https://wpml.org/documentation/support/language-configuration-files/

Alternately, you can go to WPML -> Translation Management -> Multilingual Content Setup and change the settings to translate manually instead of using the Translation Editor. This will open the translated pages in the native WordPress editor and you can add/change the shortcode as needed.

Please let me know if you need any further assistance and I will be happy to help.

April 11, 2018 at 7:11 am #1590174

julienF-5

Hello Lauren

Thank you for your support

I found a solution by deleting pages and creating the news pages with the content

Thank you

Best regards