Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 4 voices.

Last updated by Carlos Rojas 2 days ago.

Assigned support staff: Carlos Rojas.

Author Posts
November 19, 2019 at 5:01 pm #4974541

maximilianS-14

I am trying to:
Get back the translations to WPML. In the pictures u can see that under the sites we have now all sites. German and English. Translations in WPML are lost. The one translation was a test from me today.
Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

November 19, 2019 at 5:16 pm #4974683

Amit
Supporter

Hi, can you please update to WPML 4.3.4 and let us know if that issue was not fixed with that version.

November 20, 2019 at 8:00 am #4977459

maximilianS-14

Hello, no its not fixed.

November 21, 2019 at 1:45 pm #4988613

maximilianS-14

Can Someone please Respond. Ty

November 21, 2019 at 1:54 pm #4988847

maximilianS-14

If you recover my translation words i can translate my page again. But I need to do something now, because our page needs to be desplayed in German and English. Thank you.

November 21, 2019 at 3:07 pm #4989899

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

I´ll be helping you with this issue. I am not sure I understand fully what the state of your site is.

1. Do you mean to say that all the content is there but that they are not linked as they used to be as translations of each other? e.g. everything is tagged as "German" when they should be tagged as both "German" and "English"?

2. How many pages/posts are affected approximately? ie. how many pages should be in each language? What about taxonomies (tags, categories, attributes, etc?)

3. Do you have a backup of your site that MIGHT possibly have a database in the state where the pages were linked as translations?

November 23, 2019 at 9:58 am #5003263

maximilianS-14

1. Yes that is exactly what happened. Also all the media got lost.
2. All Sites that were translated are affected. Roughly 30. tags and everythin off the media was gone. I recovered the media with a plugin but all the information is gone.
3. I have a backup but there were imrpovements within the page in the meanwhile that i dont have fully documented.

I just checked the status and all the installation information from wpml plugin is gone again. I didnt do any updates or anythin in between. So WPML must have reset itself.
Picture is attached

November 24, 2019 at 8:50 pm #5007705

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

1. OK
The media is most likely not "lost" but as the WPML plugin is no longer configured, it is simply not "visible". I will have to check the databae to be sure.

3. Backup
Great news! We only need a backup of one table "wp-icl_translations" This holds all the information of the translation groups (ie. which pages are linked to which as translations) so that we can restore the pages to their correct translation group.

Could you send me the copy of the database backup? Please use a file transfer service like WeTransfer, Dropbox, Filetransfer..etc and only send me a downloadable link .

4. I can also try to recuperate the WPML settings from the backup so you should not have to redo the setup.

I wait for the link to the database backup and also for system access information in the private area that I am opening up for you. Please make sure that the userid/pwd you provide has admin priveleges.

Thanks

December 5, 2019 at 4:31 pm #5078601

maximilianS-14

Hello,
sorry for late Response. I will check the backup ASAP.
TY

December 7, 2019 at 9:32 am #5086673

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello,
My name is Carlos and I will be taking this ticket because our colleague Yvette is on vacations.

I will be waiting for your message.

Best regards,
Carlos

December 8, 2019 at 2:20 pm #5088879

maximilianS-14

Hello Carlos,

so it seems like WPML keeps reseting itself. It always wants me to configure the app even though i already did this. Unfortunately I have no backup of the database only of the website. The database backup only goes back 14 days. So I made a sql copy of the current database and here is the dropboxlink for u: hidden link . How can we make sure that WPML dont resets itself? If you need acces to the WP-website please tell me.

December 8, 2019 at 9:15 pm #5089809

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,
Thank you very much for your feedback.

While we check the database I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all plugins except WPML plugins.
- Activate a default WordPress theme, like Twenty Nineteen.
- Run the WPML setup again.
- If the issue is gone, activate one by one to see if there is an interaction issue.

Could you tell me the result of this steps?

Looking forward to your message.
Regards,
Carlos

December 9, 2019 at 3:18 pm #5093917

maximilianS-14

Hello Carlos,

I checked everythin flushed the cache and WPML is working normally. So it resets for no explicit reason.

I got an Error occurance now on my website saying:

Incorrect key file for table './AuM2/8O6aG_icl_strings.MYI'; try to repair it

Array
(
[language] => de
[context] => elementor-121
[gettext_context] =>
[domain_name_context_md5] => e426c1f84293aa2cfff2e1bd2d6a5533
[name] => text-divider-941060b
[value] => Trenner
[status] => 0
[translation_priority] => optional
[allow_empty_value] =>
)

Also i found a way to connect my translations. But it takes really long to connect all the english to german translations. Could you find any problems with the database?

December 10, 2019 at 8:53 am #5097825

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,
Thank you very much for your feedback.

I have consulted our specialists about this issue and this errors seems to be a corrupted database index. In this case you should run a repair on the table and be aware that you might loose some content, that's why a backup of the database might be created before running any repair.

Also, with the information we have so far we can say for sure that WPML didn't caused this issue.

Best regards,
Carlos