We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 13, 2019 at 6:49 am

hubertusH

Hi guys,

Unfortunately, the system is not doing what it is supposed to: For example, the menu item "Seminars" always redirects to the /en/ version. We've already looked at it with a developer, but we can't come up with a solution. We have this problem with some pages. Is it possible that you take a look at the site?

The page is: hidden link At the top right you will find the corresponding language selection. No matter which language I choose, I always get to the English version, not the Japanese, Korean etc.

Thank you so much for any help!

Hubi

August 13, 2019 at 10:22 am #4386979

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

It seems that the conflict is caused by the URL structure. I went to WPML -> Languages -> Language URL format -> Selected 'Language name added as a parameter' option -> Saved the changes -> Re-saved the permalink structure and now the issue is solved.

Could you confirm that the issue is solved?

Kind regards,
Carlos

August 13, 2019 at 10:25 am #4386987

hubertusH

Hi Carlos, thank you so much for investigating. But our aim is not to change the URL structure from /kr/seminars to /seminars/?lang=kr since we are afraid of now losing our organic ranking. is there something which causes the conflict? On other installations we don't experience any problems by having the permalink structure like /kr/seminars

Thank you so much!
Hubertus

August 13, 2019 at 11:26 am #4387385

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Hubertus,

In this case I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

August 16, 2019 at 11:15 am #4405993

hubertusH

Hi Carlos,

I deactivated everything and still have the problem. Also updated theme, system and plugins to the most recent versions. I am running out of ideas, we have this problem especially on this page: hidden link (Seminar page) which is always re-directing to /en/seminars. I checked redirects, but there are no redirects set from KR to EN version of this seminars page. Running out of ideas now

August 16, 2019 at 12:41 pm #4406309

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Hubertus,

I tried to access the site to take a deeper look at the issue but the credentials you shared aren't working. I have set your next answer private so you can provide new access credentials.

Regards,
Carlos

August 16, 2019 at 3:44 pm #4407393

hubertusH

Hi Carlos,

I reset the data to the credentials I sent to you earlier. Please see my first posting above.

Thank you so much!!!

August 19, 2019 at 5:50 am #4413601

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Hubertus,
Thank you for reseting the credentials. I was able to log in the site again.

I took another look at the site and the Seminars page seems to be working correctly now. I switched to all languages, including Korean and I can't see any problem (see attached image).

Regards,
Carlos