Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by thorstenR-2 10 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
November 4, 2019 at 5:36 pm

thorstenR-2

There is a problem with the String Translation table in your site. This problem is not causing a problem running the site right now, but can become a critical issue in the future. WPML support team knows how to fix it. Please add a message in the relevant support thread and we'll fix it for you.

November 4, 2019 at 6:01 pm
November 5, 2019 at 9:44 am #4887029

thorstenR-2

Hi, any news for me as it is really frustrating for me as my client gets nervous ...

November 5, 2019 at 5:55 pm #4892409

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I installed your site locally and found that there were WPML tables missing. I added this function to the theme functions.php file and it created the missing tables:

function wpmlsupp_1891_fix_missing_icl_tables() {
    if( function_exists( 'icl_sitepress_activate' ) )
        icl_sitepress_activate();
}
add_action( 'wp_footer', 'wpmlsupp_1891_fix_missing_icl_tables' );

Once you have added that to functions.php, load the front of your site one time. This should resolve the missing tables.

After that, if you go to WPML -> Languages, do you see your languages installed? If not, access the database and in the icl_langauges table, change the active value to 1 for any languages you would like activated.

After this, try running the cleanup steps in WPML -> Support -> Troubleshooting. If you see any errors or have trouble with these steps, check the permissions on the WPML folders.

Please let me know the results.

November 6, 2019 at 8:49 am #4895861

thorstenR-2

Hi Lauren. I followed all your steps. Pages and posts are accessable again and it seems it's possible to do translations. The only thing: the warning message still appears.

Thorsten

November 6, 2019 at 1:11 pm #4898735

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay, I'm glad we are at least making progress! As for the message, would it be possible for me to install a plugin so I can access your database? I would like to try manually removing this message from the wp-options table and see if it returns. Sometimes it is a false error, and sometimes I can delete that entry and it resolves the message. Let me know if that would be okay.

November 6, 2019 at 2:56 pm #4899591

thorstenR-2

Of course you can, but does this message mean something is still not okay with the site?

November 6, 2019 at 3:01 pm #4899655

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Not necessarily. It could be that the message was generated previously due to the missing tables, but it still showing. If I manually delete it, and it returns, then we know there is still some underlying issue. I'll let you know shortly after I have some time to test this.

November 6, 2019 at 3:04 pm #4899731

thorstenR-2

Great you're helping me out ...

November 6, 2019 at 3:08 pm #4899757

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Currently when I try to access your site, I get the message "The page you are looking for is temporarily unavailable.
Please try again later.".

Please let me know when your site is backup and running so that I can further troubleshoot. Thanks!

November 6, 2019 at 5:45 pm #4900731

thorstenR-2

Sorry, the link in the private message ist working again - checked it

November 6, 2019 at 7:12 pm #4901141

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It looks like the error message is resolved and it has not come back after I removed it. If you do see it return, please let me know. Otherwise, it looks like we were able to resolve the issue by repairing the missing tables.

November 7, 2019 at 6:49 am #4902999

thorstenR-2

Hi Lauren. Thank you so much. Everything seems to be okay right now. Thank you for your support!

November 7, 2019 at 6:50 am #4903003

thorstenR-2

My issue is resolved now. Thank you!