This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 48 replies, has 3 voices.

Last updated by Sumit 8 months, 3 weeks ago.

Assigned support staff: Sumit.

Author Posts
August 5, 2019 at 2:13 pm

ninaB-6

I have tried to: translate a page from English to German, the advanced translation editor shows me a 100% correctly translated page but the page itself displays a mix of English and German

Link to a page where the issue can be seen:
hidden link (should be all in German)

I expected to see:

Instead, I got:
hidden link

August 6, 2019 at 8:47 am #4345439

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Have you used WPML Classic Translation Editor for translating the hidden link page?

Because when I open it for translation it is showing as translated using WPML Classic Translation Editor. Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

August 6, 2019 at 10:44 am #4346555

ninaB-6

Yes, That's right, it's the classic translator.

August 6, 2019 at 6:05 pm #4349831

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Recreate ST DB cache tables

4) Update hidden link page after a minor change to refresh the translation settings

5) Update the translation of hidden link page to refresh the translation settings

--
Thanks!

Bigul

August 7, 2019 at 8:17 pm #4358087

ninaB-6

HI Bigul,
I followed all of your recommended steps. I retranslated all the parts that the advanced translator was telling me and saved and completed it at 100%. Now I open the page and there are even more parts in English (and not German) than before! Please advise and also tell me where in WPML I can find the previous translated work as I would hate to have to do it all again. I' ve struggled with this issue a few times now (different pages) and would really appreciate if it could work reliably. Thanks for your help

August 8, 2019 at 12:24 pm #4362733

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have a request for troubleshooting the issue. Please try the following steps and let me know your feedback.

1) Create a new post or page for testing
2) Translate it
3) Update the original language post or page
4) Update the translation
5) Check the translated post/page is showing the correct result or not

--
Thanks!

Bigul

August 13, 2019 at 6:11 pm #4390201

ninaB-6

Hello Bigul,
I don't know exactly if it works - I did try, but wasn't able to open the German page of the new post at all after translation. Please also let me know how that would solve the problem of the existing "about me" page, where after updating it now even more parts show up in English than German. I really need to fix this as language is my business and if I can't even get my website right in languages I don't think that sends the most professional message.
Thanks for your time. Nina

August 14, 2019 at 3:40 pm #4396487

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nina,

Thank you for the updates. I was able to visit the translation of the test Post. Please check the following URL. It is happening because the Post status of English test Post is *Draft* now.

hidden link

I am checking the issue with our team now. So can you please share the URLs of the translated Pages other than *About Me* having mixed contents.

Also please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 17, 2019 at 2:14 pm #4410185

ninaB-6

Hello Bigul,
Sorry for the delay. Yes, please use duplicator.
I had tested the page "live" then just put into draft after so it doesn't appear on the website.

Mixed content pages:
- about me
- hidden link
- hidden link

Thank you and have a good weekend, Nina

August 19, 2019 at 6:19 am #4413667

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nina,

Thank you for the updates and permission. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

August 20, 2019 at 8:03 am #4421425

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nina,

The bug is existing after the initial debugging steps. Therefore I have shared the details with our team and waiting for the expert opinion now. We will get back to you soon. Please wait.

--
Thanks!

Bigul

August 22, 2019 at 7:45 am #4437267

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nina,

I am getting the expected result in my local copy after the following steps. Please try it after a full site backup and let me know your feedback.

1) Open the hidden link page for edit
2) Edit the page with Avia Layout Builder
3) Make some minor changes to refresh the translation settings
4) Update the page
5) Update the German translation using WPML's Classic Translation Editor

Please check the attached images for more details. Somehow the theme style is missing in my local copies.

--
Thanks!

Bigul

August 26, 2019 at 11:32 am #4457983

ninaB-6

Dear Bigul, I have done all the above steps:

- gone over the English version of the about me page and made some changes/improvements.
- updated it
- updated the German translation with the classic editor as that is the one that came up, saying I am working on an old translation.
- I updated the translation.
- I don't see the result 🙁

August 27, 2019 at 6:26 am #4463029

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Nina,

Thank you for the updates. I have a doubt. Just to make sure you have updated the German translation using WPML's Classic Translation Editor like the attached image, am I right? Please check and let me know your feedback.

--
Thanks!

Bigul

August 27, 2019 at 9:03 am #4464065

ninaB-6

HI Bigul,

Yes, I saved everything as in the image (even though I don't see save in your image), but the boxes are all checked, all content is translated, it says 100% and I click "save and close".
I tried to now open the English about me page again, made a minor change, update and click on update German translation which this time takes me straight to Advanced Translator not the classic one. Advanced is only 81% translated, how is that possible? I didn't make any further changes or complete the translation in Advanced Editor.

I also have one question: the first 2 text boxes that come up in the original are the yoast meta fields. I used Yoast a long time ago but the plugin has been deactivated at least 6 months to 1 year ago. Why does that still show up?

Thanks for your time.
Nina