Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 3 voices.

Last updated by Sumit 2 years, 7 months ago.

Assigned support staff: Sumit.

Author Posts
January 23, 2018 at 2:38 pm #1493985

mathieulaflamme

I installed wpml on y site here, hidden link

I sent my pages and portfolio items to translate but had difficulties. I realized my plugins were a little old and I updated. Fixed the first problem, so now all my pages are translated, but none of them are linked to the original pages. Please help!!!

tried to give you the debug info but and followed the instructions but I can't find it:-(

January 24, 2018 at 6:33 am #1494787

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ll be helping you with this problem.

1. Clarifications
Do you have a backup of your system before the upgrade? I would only need the database and most specifically, the table icl_translations.

2. Connect with Tranlsations
If you do not have a backup of the table and, indeed, the current version of the icl_translations table has lost the "links" (e.g. field trid in the table) between translation groups, then the only way to link the translations is by "connecting" them manually through the editor.

If you enter the editor of one of the posts, you will see in the Languages sidebar, the option to "Connect with tranlsation",. This tool will allow you to select a page in other languages to link with as a translation. This action will then record a link in the icl_translations table.

Unfortunately, this has to be done manually for all posts.

3. Backup of icl_translations
If you have a backup of the icl_translations table, then you can simply import this backup into the current database and it should re-establish the links.

I wait for your clarifications.

January 24, 2018 at 7:11 pm #1495910

mathieulaflamme

Unfortunately, I think it's more complicated that that. See my screenshot, the pages ARE linked. But when I click on preview or permalink the french page won't open. The language bar appears, but doesn't offer to go anywhere.

January 24, 2018 at 8:39 pm #1496011

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK.

Please do the following steps:

1. Activate the WordPress Debug
Follow these steps:
hidden link

2. Install and activate the ARI Adminer plugin

3. Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

January 30, 2018 at 6:13 pm #1502051

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thanks for the details. I can see that the issue is at the time of saving the translated string to the post-content of the translated post.

Something is going wrong which then interrupts the save and loses the existing post-content along the way.

Please turn on WordPress debug mode by editing your wp-config.php file and changing this line

define('WP_DEBUG', false);

to this

define('WP_DEBUG', true);

The config file is found in the root directory of your installation.

Please let me know when this is done so I can continue my testing/investigation.

January 31, 2018 at 12:45 am #1502296

mathieulaflamme

"Please turn on WordPress debug mode by editing your wp-config.php file and changing this line" I do not know how to do this!!!

January 31, 2018 at 12:49 am #1502297

mathieulaflamme

Plsee see attachment

January 31, 2018 at 5:14 am #1502350

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I got that error too when I tried to use a plugin which is why I asked you to do it.

You will have to access the file system directly. If you could provide the FTP details, I could do it for you but it seems you have security enabled so it is not possible to do it via WordPress.

Have you got the FTP username/password yet?
I am opening the private area for this info in case you can communicate it,

January 31, 2018 at 5:01 pm #1503093

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Perfect - I was able to edit the file to activate Debug mode. Thanks.
Continuing with the investigation

January 31, 2018 at 5:41 pm #1503154

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. What is the state of your site?
Are you able to do the following tests:

1.1 Temporarily deactivate all non-WPML plugins and the create a test page that has only one page builder element (e.g. contact form).

Are you able to successfully save this using the TE?

1.2 Now with all the non-WPML plugins still deactivated, switch your editing mode to use the Manual Translation
(WPML -> Translation Management -> Multilingual Content Setup -> How to translate posts and pages)

Then do the same actions of creating a new page with a single element, use the method of creating first a duplicate in the target lagnague and then translating it independently, then edit the element using the page builder in the target language.

Does it save as expected?

2. Builder compatibility
My suspicion is that while we can parse the Nectar custom shortcodes, for some reason, there is an incompatibility at the time of saving the codes to post-content. If you need to push forward with your project, I would suggest that you do NOT use the Translation Editor.

Please send me the zip of your theme that includes the Nectar codes and builder. I will then test on a local server to see if I can recreate this scenario and if I can, I will then escalate this issue to our compatibiltiy team to contact the theme author.

I am opening the private area for a downloadable link. Or, alternatively, you can place the zip somewhere on your filesystem since I have the CPanel access.

Thanks for advising on the tests and providing the theme zip.

January 31, 2018 at 10:12 pm #1503480

mathieulaflamme

"If you need to push forward with your project, I would suggest that you do NOT use the Translation Editor."

So how do I make this work. What's the temporary work around? And how do I get this fixed? I need to hand a working wordpress site to my client very soon. Or I will need to recreate it exactly as it is now and that will take me a lot of work. Please let me know what realistically what are my options. Thanks

February 1, 2018 at 7:04 am #1503610

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Manual Translation / Native WordPress
As you said: "...The only thing that saved to the page was using the regular Salient Theme wordpress editor. "

This was my finding as well. I could use the native wordpress editor with your theme, and only in this way was I able to save the changes made to the post-content in the database.

Here is the specific steps of how to use any pagebuilder with manual translation:
https://wpml.org/documentation/translating-your-contents/page-builders/translating-content-created-with-page-builders-using-manual-translation/

2. how do I get this fixed?
Here are the steps I need to do:
2.1 Using the zip of the plugin, install on a fresh installation and see if the same problem happens.

2.2 . If it does, the issue gets escalated to our compatibiltiy team and they will contact the theme author to collaborate on a fix. If they are able to "fix" the theme and there is a working relationship, they might offer you a temporary fix..however, it is normally the policy of WPML to not change code not written by our own programmers. Fixes to themes are delivered by the theme authors.

2.2 If I am not able to reproduce the issue on a clean instalation, then I will take a snapshot of your site using the Duplicator plugin and it will be escalated to our 2nd tier support for further investigation and resolution.

3. Realistic Options
The problem seems to be specifically with the Translation Editor and the custom VC Nectar shortcodes. Our Translation Editor can parse the page builder elements, but it is not able to save them to the database. I´ve asked around about this kind of issue and I also researched our internal database for this same issue. But I have not been able to find another case like this.

This is echoed by your own experience: "..keep in mind I use the same version of this theme with wpml on two other sites and for the moment at least I don't' have any problems...:"

This indicates the problem might be related to the actual server settings or perhaps a database collation issue as the problem is at the time of saving.

This will be up to our 2nd tier supporters to go further into.

So, realistically, depending on your deadlines, I would say to push forward not using the Translation Editor. As stated before, you should be able to always translate pages manually and without Translation Editor.

4. Theme Compatibility
You wrote: "..I have had nothing but problems for a 6 months with wpml and my theme.."
I can see that right now, the compatibility team is going through another round of testing with the author and are sorting through a number of compatibiltiy issues. The current status is "Waiting for Author". I should add that we have been attempting to work with the author since 2015 but it looks like now there is activity and the last update was just last week. Please note that the theme is not yet listed as compatibile with WPML:
https://wpml.org/documentation/theme-compatibility/

I hope I´ve been able to answer your questions. I´ll be testing the theme now on a fresh installation.

Do I have your permission to take a snapshot of your site if required? It will be a reduced file copy not includine wp-uploads.

February 1, 2018 at 7:26 am #1503622

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi

The access to your site is not working - can you please reset the wp-admin details?
Thanks. I am opening the private area for the username/pass

Update:
I installed the version of Salient that you provided. I see now that it has its own version of Visual Composer bundled in.
I created a sample page using the builder with a few elements and translated it with the Translation Editor.

All worked as expected. I was not able to reproduce the issue.

I would like to now take a snapshot of your site with the Duplciator plugin to escalate to our 2nd tier group.
Thanks

February 1, 2018 at 6:12 pm #1504521

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I´ve escalated your ticket to the 2nd tier group. While preparing the internal escalation ticket, I realised that the problems happened after an upgrade and after a translation was already started. I wonder if this has a particular revelevance.

1. Start a translation with TE but do not finish it
2,. Upgrade
3. Problems begin with TE unable to save to wp-posts table.

Can you recall what level of WPML you previously were at? Was it a large upgrade?

This would lend support to a problem with Database collations. In any case, the 2nd tier group will certainly look into that. I just thought if you coudl provide more info, I could pass it on.
Thanks

February 1, 2018 at 6:15 pm #1504523

mathieulaflamme

I went to the back end and deleted the french pages and unlinked them. I followed the instructions to manually translate them, and now the entire site appears to be offline. I am in contact with my hosts technical support.

The topic ‘[Closed] Pages aren't being linked?’ is closed to new replies.