Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 3 voices.

Last updated by Sumit 3 years, 7 months ago.

Assigned support staff: Sumit.

Author Posts
February 1, 2018 at 7:05 pm #1504571

mathieulaflamme

Ok, so my entire site crashed, you can watch when I first notice it happen here hidden link

I contacted support and somehow they managed to turn off all the plug ins and get me access to the back end. They said a plug in was causing it. I turned of Salient Visual composer and it still didn't work. I turned off Wordfence security plugin and it still didn't work. I turned off all 3 of your plug ins and the english version of my site came back online. What do I do now...

February 6, 2018 at 12:31 pm #1508491

mathieulaflamme

Hi
I desperately need to know that you guys are still working on fixing my issue. I've created a site I need to hand over to my client, and I need a fully functioning version. I haven't heard back from you in some time, despite my problems getting worse and you may have seen in the last video I uploaded. Can you please confirm what is going on and what is the path for me to solve this issue. Thanks

February 6, 2018 at 2:08 pm #1508662

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello
Unfortuantely, there is a backlog in 2nd tier. I´ll take a look now at your site and see if I can help in any way.

February 6, 2018 at 2:32 pm #1508694

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello again,

The theme options settings were still pointing to the "Home" page in French and this is why it considered it to be the "Front Page".

I changed that to now point to "Home" in English and so things are working.

I can navigate your site in 2 languages. Can you?

February 6, 2018 at 2:35 pm #1508700

mathieulaflamme

I can navigate in two languages, yes. But I've had to completely uninstall wpml and instal another plug in in the mean time to get it to work. I want to install your plug in again, but I'm very scared what it's going to do to my site.

February 6, 2018 at 2:49 pm #1508720

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Right now the plugin modules are all activated. The problem you had had to do with theme settings.
Am I looking at the wrong site?

EverythinActivated.png
February 6, 2018 at 5:36 pm #1508964

mathieulaflamme

hidden link

February 6, 2018 at 6:52 pm #1509038

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

???

YepSameSystem.png
February 6, 2018 at 6:59 pm #1509047

mathieulaflamme

Yes, but look now. I deactivated wpml and it's still being translated (by Weglot Translate not wpml) I turned it off because I was not able to show my translations. None of them. That's what this ticket is about. Am I missing something?

February 6, 2018 at 7:18 pm #1509075

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Yes I think we are not understanding each other.

I escalated this ticket because we determined that it was not possible to create translations using the Translation Management / Translation Editor.

You were still able to create translations using the manual translation method.

However, you then, in urgency, wrote to say that the site was broken and nothing was working. I connected to your system and saw that you had the wrong "Home" page configured as the "Front page". This was confusing things.

I then, corrected this and so your French "Front" page is "Acceuil" and your English "Front" page is "Home". You still had to enter translated content into the Acceuil page. We do not support automatic machine translation so this was something you still needed to do.

THen you said that the plugins were breaking your site when activated. I have now deactivated WeGlot and re-activated the WPML Modules. I added a footer language switcher and I can see that the Home site shows the expected content in both languages.

Since you did not enter any translated text in the page "Acceuill" , I pre-pended the text "(FRENCH)" on all text areas so that you can see that it is indeed a different page.

The site is not broken, WeGlot is deactivated, WPML modules are activated. You still need to transalte the FR front page.

This ticket is still about the Translation Editor problems with your theme. It is not about WPML breaking your site.

Are we on the same page now?

FRSite.png
EnSite.png
February 7, 2018 at 7:08 pm #1510508

mathieulaflamme

Ok, yes. Well I had done that page though. All the pages were done, all of them are gone. But I will re-do them without using your backend, and soon 2nd tire support will help to get that working, correct?

February 7, 2018 at 8:38 pm #1510613

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

1. You wrote: "all the pages were done"
Just to be clear: do you mean to say that "all the pages were done" using the Translation Editor?

If so, we have determined that there is some issue with using the Translation Editor on your site. And this is why we have escalated the issue to our 2nd tier.

2. You wrote: "..I will re-do them without using your backend,.."
If you mean you will now re-translate WITHOUT using the Translation Editor and instead use the manual natived WordPress editor. Then yes, I agree. We have already determined that using the manual method for creating translations works.

3. Finally, yes, 2nd tier will help determine what is causing the conflict that is not allowing the Translation Editor to save your translations to your database.

I am now sending this ticket back to 2nd tier.

February 8, 2018 at 5:19 pm #1511915

mathieulaflamme

1. yes. but I lost the translations. I'm having them redone today.
2. yes, I will redo them without using your translation editor. I've started translating now, and I can see that it's working but I'm still having a problem, one that I also had last week. When I work on a french page, like the home page, and press preview it always takes me to the home page. Same with all the other pages, when I click preview it takes me home. When I save the page and click permalink it also takes me home. It did this last week. Very weird. It's also doing it today on one computer (all browsers) but then it's not doing it all on from my other computer...What's up with that do you think? Bottom line, is there anything to worry about?

February 19, 2018 at 7:07 pm #1522774

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Hello

I have word from 2nd tier regarding the problem with using Salient with the Translation Editor.

They have pointed out that your version of the Salient Visual Composer is not at the required level.
1. Please update Salient Visual Composer
2. Please provide me a copy of the updated Salient Visual Composer so that we can also test this on our replica of your site.

Thank you - I am opening the private area for a downloadable link to this plugin. Please use a file sharing service to send us the zip.

Thanks

UpdateRequired.png
February 19, 2018 at 7:26 pm #1522791

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Paris (GMT+02:00)

Bear with me as I serve as an "in-between".

1. Salient Visual Composer
I think our 2nd tier has actually been able to reproduce the issue on a fresh installation and this is why he does not have the most recent copy of the Salient Visual Composer.

Therefore, I believe the image might be from the 2nd tier supporter´s personal site. If you have it, then I can extract it from your site.

Sorry for the confusion.

2. Duplicaor package
I am not sure what you see on your end. The only way I can ask for a "link" from my end is to ask for a Duplicator package. Sorry if this is confusing matters, I won´t do that again.

3. Zip of Salient Visual Composer version 5.2.4
To extract a zip of the Visual Composer, you can access the file system and compress (create a zip) of the plugin folder.

Then upload the zip to a file sharing platform and send me the link where I can download it.

The topic ‘[Closed] Pages aren't being linked?’ is closed to new replies.