This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 41 replies, has 3 voices.

Last updated by Sumit 1 year, 8 months ago.

Assigned support staff: Sumit.

Author Posts
February 19, 2018 at 7:29 pm #1522792

mathieulaflamme

I am using a new version that you v8.5.4

this one was given to me by the author with his personal assurance it worked.

February 20, 2018 at 10:48 am #1523379

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thanks for that clarification, our 2nd tier supporter will be contacting you directly now going forward.

February 20, 2018 at 2:21 pm #1523727

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am Sumit from 2nd tier support.

Yes, Theme is updated but Salient Visual Composer plugin is not updated. You are not seeing any update because you have turned off this option.
Please go to Dashboard > Salient > General settings > Disable Theme Reccomended Plugin Notifications: Please turn off this option.
Once it is done you will be able to see a new option under Appearance > Install plugins: there you can update Salient Visual Composer to 5.2.4 which the minimum required version of the plugin to use with this version of the theme.
Can you please do that? And let me know if this fixes the issue?

Thanks

February 20, 2018 at 4:33 pm #1523931

mathieulaflamme

Hi
You were right about having the notifications to update included plugins turned off. My bad. Unfortunately though, the problem persists.

I updated visual composer, then created this page

hidden link

Clicked on translate. Filled in the fields with only the word FRENCH. I published the page and voila...none of the french is making it over. Zero.

When I go back to the back-end and change the language of the page I see that nothing has been copied over to french, and the page is not being published either.

I do not believe updating visual composer changed anything at all. Please let me know what to do. Thanks

February 21, 2018 at 1:26 pm #1524928

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you for testing this. Is it okay if I download that updated plugin from your site for debugging?

Thanks

February 21, 2018 at 1:32 pm #1524933

mathieulaflamme

Sure, please do what you got to do. As long as the site isn't disrupted then it's all good. Thanks!

February 22, 2018 at 2:05 pm #1526267

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Thank you!
I checked the theme and found that author using one of the WPML filters in the wrong way thus blocking WPML from saving the post content.
I have forwarded this our compatibility team so they can contact the theme author.
Meanwhile as a workaround, please follow these steps:-
#1 Make a complete site files and database backup
#2 Go to \wp-content\themes\salient\functions.php line number 3434
#3 Replace

add_filter( 'wpml_pb_shortcodes_save_translation', 'nectar_wpml_filter_save_translation', 10, 3 );

with

//add_filter( 'wpml_pb_shortcodes_save_translation', 'nectar_wpml_filter_save_translation', 10, 3 );

#4 Then edit the page in Translation Editor and save again. The content should be updated.

Thanks

February 22, 2018 at 2:30 pm #1526300

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

As per the feedback from compatibility team, pleases also test portfolio items if you are using them else ignore this comment.

Thanks

February 26, 2018 at 3:44 pm #1529412

mathieulaflamme

An email from you guys this morning about this ticket, do I need to do anything? Please let me know thank you

February 27, 2018 at 5:21 am #1529958

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Did you get my these two replies?
https://wpml.org/forums/topic/pages-arent-being-linked/page/3/#post-1526267
https://wpml.org/forums/topic/pages-arent-being-linked/page/3/#post-1526300

Thanks

February 27, 2018 at 1:31 pm #1530514

mathieulaflamme

Hi
Ok, thanks, I had not seen them. So if I add that code to my site, what happens when I update my site again later? I'll have to re-add it? Will it break everything again as it did last time? Do you have any news from the site author? Thanks!

February 28, 2018 at 12:01 pm #1531673

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Once the changes added this will fix the issue. These changes will go into the theme.
Now, about the update, it depends on how soon/when the author adds this code and in which version it will be released.
We have not contacted the author yet and testing this code. If you wish you can contact the theme author to make this process fast.

Thanks

The topic ‘[Closed] Pages aren't being linked?’ is closed to new replies.