This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by danielJ-53 3 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
June 29, 2019 at 3:54 am

danielJ-53

Hey guys,
After translating the pages of my site, when I switch it to Spanish (primary language is English), part of the each page gets messed up. It's like there is a side bar in the translated page as the content gets "pushed" to the side (screenshot). I read your documentation but couldn't find a solution.

Would you mind having a look on it to see if you could help me fix it, please?

I'm using Elementor + Ocean WP

Thank you!

Sintia

June 30, 2019 at 10:18 am #4114013

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. I have tried to login to your site but some security plugin is restricting me to open wp-admin page of your site.

Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

- Please make sure page settings are the same for both languages.

- Please delete all sort of caches on your site / server cache / plugin cache (LiteSpeed Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable LiteSpeed Cache plugin temporary.

- If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Please let me know if this resolves your issue or you need further assistance with this issue.

Thank you

July 1, 2019 at 1:45 pm #4119599

danielJ-53

Hi Noman, thank you for replying.
I'll do all tests that you've recommended, however, it might take a while as I'm kinda busy this week. Is it possible to get back to the same ticket when I do it or it is going to expire after a while and I'll have to open a new one?

July 1, 2019 at 4:07 pm #4121095

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Yes, you can reply me on same ticket.

Thank you

July 6, 2019 at 11:45 pm #4156505

danielJ-53

Hi Noman, thank you for that,

About logging in to my site, the hosting company blocks requests for files that are frequently attacked such as WordPress login in browsers that don't have a few languages installed. The languages are: Spanish, Catalan, Galician, Euskera.
It is not necessary to enable them all, or that they are the main use, simply that there is one installed is enough.

About the side bar, I fixed it by going to each translated page (Spanish) in Elementor and edited the layout. In fact, I’m not really sure if I’m allowed to edit the translated pages in Elementor. Please let me know if it's not a good idea.

Although I had fixed the side bar, I still have some problems when switching the language, even after I followed the steps that you told me:

- Increased WP memory to 512MB.

- Settings are the same for both languages.

- I deleted caches on the site / plugin / browser.

- About disabling all the plugins except WPML: I need to have Toolset and Elementor enable because without them, I'm not able to see if WPML will work. Also, some reasons why I need them are:
* My header is designed without Elementor and it's where I have the language switcher.
* ALso, one of the problems when switching languages is that I have a view made with Toolset and the page where my custom search displays its results gets messed up after changing language to Spanish (secondary language).
*I have a template (made with Elementor) to display the custom posts from Toolset:

- After disabling most plugins (except Toolset/WPML/Elementor/Elementor Pro). This is what I got:

With Twenty Seventeen Theme:
1. General layout messed up (all pages - both languages).

2. Page “Our boats”, where I have a Toolset view displayed:
When I switch to the secondary language (Spanish) the layout gets messed up. Also, it doesn’t display all results properly / images from the results disappear.

3. Template (made with Elementor) to display the custom posts from Toolset:
*Layout gets messed up.
*Header disappears when current language is primary (English).
*Language switcher disappears when current language is secondary (Spanish).

With Ocean WP theme:

1. Template (made with Elementor) to display the custom posts from Toolset:
*Header completely disappears when current language is set up as primary (English).
*Language switcher disappears when current language is set up as secondary (Spanish).
*Slider disappears when Spanish (seconday language) is set up.

2. Page “Our boats”, where I have a Toolset view displayed:
When I switch to the secondary language (Spanish) the layout gets messed up / also, it doesn’t display all results properly / images from the results disappear.

I hope it's not too confused explanation.

Thank you.

July 7, 2019 at 5:15 pm #4158021

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Sorry for the delay, I ran into my weekend, my off days are Friday and Saturday. I am going to check this issue further and let you know my findings soon.

Thank you for your cooperation and patience.

July 8, 2019 at 12:30 pm #4162309

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for doing above steps. It seems your page options have different values in both languages as you can see in the attached screenshot.

If you want to keep exact page layout on all languages:
- Either you can duplicate original page to secondary language and then translate text of secondary page.
- Or you can mark page settings fields to as copy from WPML >> Settings >> Multilingual Content Setup >> Custom Fields Translation so that it will maintain the same value in both pages.

Here is step by step doc for more details:
https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Thank you

July 9, 2019 at 1:43 am #4166437
danielJ-53

Hi Noman, thank you for writing back. I hope you had a good weekend!

You are right, the page settings were not set correctly. I've just doubled checked and I think now it's all equally set for both original and secondary language pages.
I also marked page settings fields to as copy (Multilingual Content Setup). I did it to all fields.

The design/layout seems to be good now, it looks the same for both content (original and translated). Despite this, it looks like there is some kind of incompatibility with Toolset. When I switch to the secondary language, the page where I have a Toolset View displayed, doesn't show the content properly. Part of the posts disappears as well as the images (please see the screenshot: Toolset View-1 / Toolset View-2).

Another thing that I noticed that the settings to display the header (made with Elementor) don't apply to the secondary language (please see screenshot: header-1 / header-2). Would that be an issue?

Thank you.

July 9, 2019 at 7:30 am #4168099

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Glad to hear that your original and secondary language pages are set now. To handle new questions/issues, I have created new tickets since these are separate issues. Here are the links to the new tickets:
https://wpml.org/forums/topic/part-of-the-posts-disappears-as-well-as-the-images-in-secondary-language/
https://wpml.org/forums/topic/elementor-header-setting/

Thank you for your cooperation and patience.

July 10, 2019 at 1:44 am #4175037

danielJ-53

Great! Thank you for that!

July 10, 2019 at 1:45 am #4175039

danielJ-53

My issue is resolved now. Thank you!