This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by katiaT 2 weeks, 2 days ago.

Assigned support staff: Bruno.

Author Posts
September 17, 2019 at 2:48 pm #4589327

katiaT

I am trying to:

Save content in pages, but WordPress won't update anymore.

Link to a page where the issue can be seen:

all pages, this is an example

hidden link

I expected to see:

My content saved.

Instead, I got:

A red alert banner that my pages can't be updated. Also, a flashing saving (the blue text) button.

September 18, 2019 at 1:38 am #4591479

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please as a test, could you disable all non-WPML plugins, switch to the default theme and see if the problem persists?

If the problem is fixed, please, enable the plugins one by one to see if there is any compatibility problem between these plugins.

Thank you.

September 18, 2019 at 3:16 pm #4597863

katiaT

Yes, I disabled all plugins but WPML and switched to the default WP Theme. The problem persists.

However, it is only a problem on my English domain hidden link. I had not trouble saving on the hidden link. WPML switches over to this domain when one clicks on the English flag.

Katia

September 19, 2019 at 12:35 am #4600389

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Katia,

Thank you for testing this. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 20, 2019 at 3:10 am #4609089

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you. I've used the All in One Migration plugin and I did a copy of your site. I will install it on my test environment and soon I will contact you.

Thank you.

September 20, 2019 at 3:32 am #4609523

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

These could be related to some compatibility with W3TC. I have forwarded your ticket to 2nd tier support so they can test it. Soon we will contact you.

Thanks.

September 25, 2019 at 2:38 pm #4639927

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. The problem was related to W3TC that was caching and redirecting. To fix the problem it was necessary to follow the steps below:

- Please go to Performance > Page Cache and add the secondary domain in Cache alias hostnames. Please, see the attached image;
- Then clear the cache and clear the browser cache;

After following these steps the problem has been fixed. Could you please test and verify that your site is working properly?

Thank you.

September 25, 2019 at 3:17 pm #4640391

katiaT

Hello Bruno,

Thanks for looking into my page. Unfortunately, I still get the same error.

September 25, 2019 at 3:24 pm #4640547

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Have you tried editing your site using only the ".de" domain (both languages using the ".de" domain? Also, have you cleared your browser's cache?

Thank you.

September 25, 2019 at 3:32 pm #4640575

katiaT

Hi Bruno,

Cache has been emptied. No change. I haven't tried to put both versions English/German on one domain. I have chosen WPML because you guys advertise the possibility to have a page run on two domains. For a number of reasons (SEO, for example), I would like to have a .de domain for the German market, and a .com domain for the international market.

September 25, 2019 at 3:56 pm #4640795

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry for the misunderstanding. I was referring to the domain at the time of updating the content. For example, in your screenshot, I saw that you are logged in to the secondary language domain.

The correct is for you to use the primary domain to edit all the content of your site. Only on the front end should the domains be different. In this case, your primary domain is the domain ".de".

The issue you are reporting is probably caused by the fact that you entered content using a domain for each language. In short, to add and translate content you should use only the primary domain. At the front end, domains should work correctly, as expected, one for each language. I will attach a picture for you to see.

Thank you.

September 25, 2019 at 4:30 pm #4641151

katiaT

Ah, I see. However, I can't really do this through the German site. When I go to my German page in the German backend and click on the pencil symbol, I get the following (see screenshot). I can translate some fields of the page, like SEO or the description to the picture, but not the actual page content. If I am doing something wrong, please tell me. This is why I went to the English page because it was the only way that I found to actually access page content.

Kind regards, Katia

September 26, 2019 at 6:08 pm #4649529

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

From what I saw, it looks like you are using an External Translator (Espresso Translations), in some posts you are using the Translation Editor and may still be using the native WordPress editor.

This may be why the content is not displaying correctly for translation. In this case, I should recommend that you follow the steps below:

- Open the desired page
- Using the language selector at the top, switch to secondary language
- Update the translated page
- Switch to the German again
- Click to edit the translation again

I will attach some images for you to see. After following these steps the fields were displayed for translation.

Could you please check if the fields are displayed correctly on this page? Note that for other pages, you should follow the same steps if the fields are not displayed for translation on other pages.

Thank you.

October 3, 2019 at 3:51 pm #4689533

katiaT

Hi Bruno,

Sorry I am just replying right now. What you suggested does not work.

If I open the German page and try to click on the German flag it is NOT possible to switch to English. Therefore, I can't follow your other steps. If I click on the German flag, I just stay on the German site and that's it.

Please let me know what to do.

Kind regards, Katia