This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Marcos Vinicios Barreto 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 30, 2019 at 8:57 pm #4310469

Molly Fitzg

I am trying to: Update and save content

Link to a page where the issue can be seen: The entire site

I expected to see: I expected the page to update.

Instead, I got: The page updated, but 9 duplicate pages were created upon page save. We have 9 languages on our site, so we suspect that WPML is erroneously duplicating the pages on save.

July 31, 2019 at 8:01 am #4312609

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

I have checked your debug information. Can you tell me if you're using this hook perhaps?
https://wpml.org/wpml-hook/wpml_admin_make_post_duplicates/

Another thing - can you try the activating the "Duplicate Page" plugin and trying then?

I'm suspecting that this behavior could come due to one of these reasons.

If none of this helps, can you please check if this issue appears when:

- only WPML plugins are activated, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme

This will help us exclude if there is some sort of incompatibility or something else causing this, because it is not normal behavior of translation management nor we have reported cases that would indicate there is a bug.

Regards,
Bruno Kos

July 31, 2019 at 4:00 pm #4316303

Molly Fitzg

This issue persists with the extra plugins deactivated. Additionally, it doesn't happen with the plugins on within our local environment(s). We're suspecting it has something to do with data corruption in the database, as explained here:
https://wpml.org/forums/topic/pages-infinitely-duplicating-on-save/

August 1, 2019 at 5:44 am #4318905

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have checked that thread and based on it, let us try the following:

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

2. Reproduce the issue - save a page.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 10 lines or so will do. Please censor any sensitive information.

https://codex.wordpress.org/Debugging_in_WordPress

It would be expected if we see an error such as:
https://wpml.org/forums/topic/pages-infinitely-duplicating-on-save/#post-3245231

And also, can you create a Duplicator package?
https://wpml.org/faq/provide-supporters-copy-site/

Because it seems that that I will need to bring this to our 2nd tier support for further investigation.

Regards,
Bruno Kos

August 5, 2019 at 3:58 pm #4341767

Molly Fitzg

I'm currently unable to edit the wp-conflig.php file. I am, however, able to provide the duplicator package. Where would you like this uploaded?

August 5, 2019 at 5:04 pm #4342171

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates, I am Marcos from WPML Support, I will dealing with your ticket from now on. Please, upload a duplicator package so we can try a detailed investigation following these instructions: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

August 6, 2019 at 6:29 pm #4350021

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case you have some more options:

1 - You can export a dump file of your database and provide us it with your wp-content folder, just make sure to exclude any cache and media files from the wp-content folder in order to reduce its size.

2 - You can also try other migration alternatives such as the WP All In One Migration plugin (see https://wordpress.org/plugins/all-in-one-wp-migration/) which seems to be accepted in most hosts that restricts Duplicator usage.

In case you prefer to provide us with a database dump I will enable a private reply for you so you can share your download url safely. Have a nice day.

August 8, 2019 at 6:22 pm #4365365

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and your patience while waiting for a solution. I proceeded with a migration of your website and couldn't reproduce it in my local environment, I tested it with your home page that has a bunch of duplications, I deleted them and tried the save/update action again and also with a new page, in the two cases the issue is not reproduced. It is something specific to your host environment, also it seems a database corruption is not the case as the migrated copy is using your current database structure.

Can you please try the issue resolution from: https://wpml.org/forums/topic/pages-infinitely-duplicating-on-save/? it could be of help in your particular case here. Please, let me know the results. Have a nice day.