Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 3 voices.

Last updated by Bruno Kos 2 months, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
July 21, 2019 at 10:09 pm

emelieC

Our site has three languages:

- Swedish - (default)
- English (EU)
- International (non-EU)

We have translated the Swedish content to English (EU).

We recently created the International (non-EU) language. The content is exactly the same as on English (EU) so we duplicated all pages and products from English (EU) to International (non-EU).

We did this here: hidden link

And the settings were to duplicate the English EU pages to the International.

However, I have run this several times, and it still does not duplicate the english content. Some of the pages are till just copies of the Swedish.

Kind regards,

Marcus

We now see that the meta of the International pages is not translated. Instead of su

July 22, 2019 at 7:36 am #4254465

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Some of the pages are till just copies of the Swedish.

Can you show me if you examples of these pages? I like to see these originals, so that I could check their duplicates and find out what may have possibly gone wrong.

Regards,
Bruno Kos

July 22, 2019 at 9:31 am #4255485

emelieC

Ok, so please check the home page to start with.

Then if you take a look at my screenshot you can see that there are some that seem to be translated with checkmark and others that have the copy/duolicate symbol. So you will find in Translation Management the ones that are not duplicated.

July 22, 2019 at 12:22 pm #4257119

emelieC

Hello,

I have now found that all my English posts have the content overwritten with Swedish content. So something is definitely not working as intended.

I can see in my posts revision that it was 3 days ago that all posts were overwritten. And I have been very careful when mass duplicating and editing.

I believe there is a deeply rooted issue here. It might be connected with this issue that I had previously, which also might be a symptom of the same problem: https://wpml.org/forums/topic/problems-when-duplicating-products/#post-4152763

There I aslo have to do some manual change in html to get the right file.

So I think that wpml somehow has mixed up the default language, and sometimes when doing like mass duplicates, the result is really strange.

July 22, 2019 at 12:57 pm #4257541

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you tell me if you have a site backup before this occurred? Because as I check these pages now, I do not know what can I do or if there's anything I can do at all. If the content has been overwritten already on some pages, then I am unable to revert them back or figure out what's happened, because they all seem to have proper language information set and are either proper translations or duplicates, without giving me an ability to trace it where it all started.

I would need to see how has this can be reproduced - so having a clean version before it started happening, so that I could test myself.

Regards,
Bruno Kos

July 23, 2019 at 1:36 pm #4266553

emelieC

Hello,

Please make it possible to send a private reply.

Kind regards,
Marcus

July 23, 2019 at 1:44 pm #4266599

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Your next reply is set as private.

Regards,
Bruno Kos

July 24, 2019 at 8:34 am
July 24, 2019 at 8:57 am #4271881

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I'm currently downloading the files. In the meantime, can you tell me what is meant by this?

I created a new entry in the db with the lang code "in".

Regards,
Bruno Kos

July 26, 2019 at 11:21 am #4289367

emelieC

I could not add a new flag to my newly created language, where I selected lang code to be "in" for interantional. So I had to go to the database and create a new row with "in".

I think this is a common issue: https://wpml.org/forums/topic/cant-upload-custom-flag-png-file/

Just wanted you to know since you want to replicate exactly.

Kind regards,

Marcus

July 29, 2019 at 8:04 am #4297599

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I was able to restore the site on my localhost. However, I have unfortunately missed the fact that I am in fact working on both of your tickets - the second one being here.
https://wpml.org/forums/topic/international-language-not-using-english-meta/

I believe it is safe to say that both issues have the same root. Compatibility team is currently working on this, however it may not be a compatibility issue, but it seems to be a WPML logical bug which we are currently discussing.

Because this is how WPML handles this task at the moment:
- you have an original
- you translated originals into another language, English in our case
- you duplicate English pages into the international language and expect these duplicates to have English language content, and not the original Swedish as they have now

As soon as I get more feedback from our development team, I will keep you posted!

Regards,
Bruno Kos

July 29, 2019 at 11:27 am #4299063

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I believe it is safe to say that both issues have the same root.

I think I was wrong with this in fact. However, can you have a look at these results I am getting on my localhost? Can you tell me what should I be testing next?

Please note that I have tested this with only plugins required for the theme to work, in order to exclude possible incompatibility issues with other plugins.

Regards,
Bruno Kos

August 5, 2019 at 11:19 am #4340065

emelieC

Hi Bruno,

Yes, I think also it might be in the logic of how wpml works.

Even though you have given the possibility now to be able to duplicate from a translation, it is not really clear which language is the root of the duplicate.

For some simpler websites it might work well, but since we have a quite complex website, there are some things that maybe have not been thought of yet regarding this.

I am very thankful that you are taking this seriously and that you are looking for a good solution.

I am a bit afraid that we might have screwed things up on the site. But I look forward to your reply and hope there is a good way forward.

Kind regards,
Marcus

August 5, 2019 at 9:27 pm #4343113

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

My colleague is absent at the moment. I would like to take care of your ticket from now.

As I understand this topic, do you want to select all pages and duplicate using one of the secondary languages?

If so, at the moment I believe the only option would be to use the steps mentioned earlier: https://wpml.org/forums/topic/pages-not-duplicated-correctly/#post-4299063

That is, after translating a page into English, then you should duplicate the content using this translation.

My apologies if I did not understand correctly. If so, could you elaborate a bit more, for me to understand?

Thank you.

August 9, 2019 at 1:38 pm #4370877

emelieC

I have done it like that. Is this fixed?