Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: My homepage does not load and several pages result in a 404.

Solution: 1. Go to Dashboard -> Settings -> Permalinks and resave permalinks.

2. Please go to WPML -> Support -> Troubleshooting.

** IMPORTANT ** Please backup a working copy of site files and database before continuing. Look for 'Clean up' and click the following: - Clear the cache in WPML - Remove ghost entries from the translation tables - Fix element_type collation - Set language information

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by carlyT 3 years, 12 months ago.

Assigned support staff: Tia.

Author Posts
August 10, 2016 at 10:43 pm #998738

carlyT

I am trying to: configure website to be in Spanish and English

URL of (my) website where problem appears: mares.tason.us

I expected to see: The homepage that is set as the static page for each language

Instead, I got: blog page set as the homepage for english version and a 404page for the Spanish and no pages found in the admin

Steps to duplicate the issue: install and activate WMPL

August 11, 2016 at 6:36 pm #1000002

Tia

Thank you for contacting WPML Support. I am happy to help you with this.

Please go to WPML > Support > Troubleshooting.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Look for 'Clean up' and click the following:
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information

Please let me know your results.

August 11, 2016 at 10:02 pm #1000412

carlyT

Thank you this worked!