This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 8 replies, has 2 voices.

Last updated by Dennis 11 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
June 11, 2019 at 12:45 am #3990759


I am trying to: translate all contents of Pages into Arabic

Link to a page where the issue can be seen: The issue is within the WordPress Dashboard and the page is hidden link

I expected to see: all texts contents to be shown when I click on the PLUS ( + ) sign to the right of Page titles so I can have them all translated.

Instead, I got: only the header translated. Also odd enough, the top navigation menu, which is called within the same header module did not get translated.

The only text content it queries for translation is found on the Header module, which was generated by a Layout Tool [ hidden link ] by ThemeREX.

The page uses Standard WP Bakery Title modules, Calendarista plugin for the form, and EVC Image Gallery module from Extensive VC Pack.

Alternately, please send me tips which WP Bakery content modules work well with WPML. I had been informed that it is compatible but are at a loss which things to configure to make it work.

Thank you very much!

June 11, 2019 at 6:13 am #3992049



Welcome to WPML Support forum.

Below are the documentations on how to maintain compatibility with WPBakery Page Builder. Could you please review and follow the suggested steps and check if you can be able to translate the pagebuilder content in Translation Editor.

Please let me know how it goes.

Kind regards,

June 15, 2019 at 10:43 am #4026565


Hello Dennis!

Thank you for giving me a heads up on the two documents.

I tried checking out the list of shortcodes and follow the instructions on the guide by opening a page and then clicking on Classic Editor to see the source code shown.

For this example, I am using the BOOK A SPACE page where only the booking packages are translated but not the other contents (please refer to the screenshot).

I keep encountering a Title shortcode but it doesn't have a closing tag. Please check the sample code below:

[vc_row][vc_column][trx_sc_title title_style="default" title_align="center" title="Check Out Our Featured Options" description="We re-imagine collaboration by connecting people, ideas, and resources to impact our community, our surroundings, and the world. Access our offices at any time, bring your laptop, pick a spot and get to work"][/vc_column][/vc_row]

If I understood correctly, the shortcode is called "trx_sc_title" and I am not sure how to convert this into a shortcode.. I am also wondering whether it could be converted because it doesn't have a closing tag --> [/trx_sc_title]

My question is should I place closing tags manually so they can become translatable?

Also could you writedown how this trx_sc_title will look like when placed on the wpml_config.xml?

BTW, I have attached a screenshot showing how the page looks like in Classic editor view. There are page headers placed without using custom layout plugins for WP Bakery and they show up fine on WPML, but the others that make use of Rev Sliders, Contact Form 7 or some other custom layout plugins (such as the trx_sc_title shortcode) are not responding properly.

Thank you so much!

June 16, 2019 at 10:20 pm #4031221



I've tried creating the wpml-config.xml file and attached the screenshots of how it looks like along with a reference on what shortcode I placed (found within the Book A Tour page).

Please check if there's something I missed.


June 17, 2019 at 2:53 am #4031687



Thank you for your updates.

You must wrap the 'shortcode' tag with 'shortcodes' tag so the final code would like this:


Copy the above code to WPML > Settings > Custom XML configuration tab and click Save.

Please let me know how it goes.

Kind regards,

June 17, 2019 at 9:26 am #4033821


Thank you Dennis! I did miss placing the <shortcodes></shortcodes> tag and just added it.

My next question is -- where do I place the wpml-config.xml file?

I tried placing it on the WP Bakery root directory, TRX Add ons root, and Crework parent theme's root directory and then disabled and re-activated the theme and the two plugins.

When I tried to click Edit Arabic Translation of Book-A-Tour from within the Pages dashboard, I still get the same result where only the Title is shown and translated.

Thanks in advance.

June 17, 2019 at 10:32 am #4034461



You can just copy the code to WPML > Settings > Custom XML Configurations tab. Please see attached image.

Kind regards,

June 17, 2019 at 8:29 pm #4038515


Thank you Dennis!

I did as you instructed and pasted the xml codes into the Custom XML Configuration field and still get the same result as before. I have attached screenshots and copy of the page's source code in the hopes that you can check if I got the shortcode right or if I'm missing something.

[vc_row equal_height="yes"][vc_column][vc_empty_space height="" hide_on_mobile=""][vc_empty_space height="" alter_height="small" hide_on_mobile=""][vc_empty_space height="" alter_height="small" hide_on_mobile=""][vc_empty_space height="" alter_height="small" hide_on_mobile=""][trx_sc_title title_style="default" title_align="center" title="Visit Our Galaxy Life Office" subtitle="Check Out Our Gallery Below"][vc_empty_space height="" alter_height="medium" hide_on_mobile=""][/vc_column][vc_column][vc_raw_js]JTVCY2FsZW5kYXJpc3RhLWJvb2tpbmclMjBpZCUzRCUyMjM4JTIyJTVE[/vc_raw_js][vc_empty_space height="" hide_on_mobile=""][trx_sc_title title_style="s4" title_align="center" title="Check Our Office Spaces Below"][vc_empty_space height="" alter_height="small" hide_on_mobile=""][vc_empty_space height="" alter_height="medium" hide_on_mobile=""][/vc_column][/vc_row][vc_row][vc_column][evc_image_gallery type="grid" image_behavior="lightbox" images="1401,1404,1403,1282,1325,1281,1261,1264,1246,1231,1230,1327" image_size="300x300"][/vc_column][/vc_row]

June 18, 2019 at 1:39 am #4039071



Thank you for your updates.

Could you please try to edit the page. edit it in the original language. Now, make a small change on some text. Then, -undo the small change. click 'Update'. Translate the page to secondary language. Does the module appears to translation editor now?

Please let me know how it goes.

Kind regards,

The topic ‘[Closed] Pages Only Show Header Title Field when Adding a Translation’ is closed to new replies.