This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 5 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
April 25, 2019 at 2:37 pm #3683553

pimL

Tell us what you are trying to do?

I have installed WPML for translation of this website. My client is working with it. Pages that are translated get a pencil. The next day they will have the wheels, so they need work. Translations dissappear so WPML thinks that pages are not translated.

Is there any documentation that you are following?

Is there a similar example that we can see?

Check the pages page: hidden link all of them were translated and now lots of them are not.

What is the link to your site?

Credentials edited

Please advice what to do. They are using Elementor and WPML and getting desperate because they anter translations and the next day translations are gone and pages are not working.

Please help!

Regards, Pim

April 26, 2019 at 7:20 am #3688335

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please create a new Page or Post with Elementor for testing. Then translate it and check the issue is happening for it or not.

Which translation method you are using for translating contents, WPML Classic Translation Editor or WPML Advanced Translation Editor?

I have a request. Please upgrade the following configuration for the expected performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

The credentials you have shared is not working. But please don't share site credentials in the open threads. Because it is a public forum and may it harm your site.

--
Thanks!

Bigul

April 26, 2019 at 8:19 am #3688785

pimL

Hi Bigul,

I set the max input vars to 5000 and the memory to 256mb.

I created a page in elementor and see that you HAVE to translate all fields. Is there a way to say I don't want to translate this, just leave it out so the page will go to finished and stay finished or at least show up if only half translated. Or is this inevitable behavior because of elementor usage?

Please let me know, Pim

April 26, 2019 at 1:20 pm #3690943

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

Thank you for the updates. Which translation method you are using for translating contents, WPML Classic Translation Editor or WPML Advanced Translation Editor?

If you are using *WPML Classic Translation Editor*, you can copy the fields from the original language. Please check the image for more details - hidden link

Please check the following documentation to know more details about translating Elementor with WPML.

https://wpml.org/documentation/plugins-compatibility/elementor/

--
Thanks!

Bigul

April 29, 2019 at 11:09 am #3702537

pimL

Hi Bigul,

Thanks for your link.

We are using the classic editor.

I am awaiting an answer from the client. Whether they have created new fields in one page and then the translation wasn't working or they really feel that translations go missing. Which would be weird and really bad.

My one question now is is there a way around having to translate ALL fields. Sometimes a page in a different language can have less content. But I have a feeling if you dont translate everything the page wont show at all. Is that correct? And is there a workaround?

Regards, Pim

April 29, 2019 at 5:18 pm #3705789

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Pim,

Thank you for the feedback. You can copy the non translated fields from the original language in Classic Editor. Then complete the translation and check you are getting the expected result or not - hidden link

If you are still having the issue, please share a few screenshots for a better understanding of the issue.

--
Thanks!

Bigul

The topic ‘[Closed] Pages that are translated are automatically switched to not translated.’ is closed to new replies.