This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Andreas W. 4 months ago.

Assigned support staff: Andreas W..

Author Posts
May 20, 2019 at 4:25 pm #3848849

aaronJ-5

I am trying to: Remove French translation option from this section.

This site has three sections: Home, New York City, and Toronto. The Home and Toronto sections are in English and French, the New York City section is English only.

When I am on the New York City page, the translation option in the Top Menu Bar has French. I would like to remove the option to translate to French in this section because French is not available. (Additionally when I switch to french it breaks the menu. (This is a beaver themer item.)

Link to a page where the issue can be seen: hidden link

(password: tdt )

Thank you

May 20, 2019 at 6:07 pm #3849621

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

The language switcher of your homepage is showing the option for a French page, because the page exists here: hidden link

Please go to Pages and switch the language inside of the admin bar on top of the screen to French. Now delete the French homepage. The language option should now no longer be available on you homepage.

The menus will need to be generated at Appearance Menus individually for each language. Please take note that only pages, posts and taxonomies that are already translated to French are available for the French Menu.

Afterwards, you will be able to sync menus at WPML -> WP Menus Sync.

Let me know if you need further assistance.

Kind regards
Andreas

May 20, 2019 at 6:34 pm #3849731

aaronJ-5

Hello,
Thanks for the reply. I did check that before, but when I go to pages: French, I only see three pages (Home, About Us and Contact) and the new-york-city page is not one of them.

And just to clarify, the home page of the site is meant to be in French, it is only the New York landing page and that section of the site that should not be in French.

Homepage: hidden link

New York Page: hidden link

Thank you.

May 20, 2019 at 10:01 pm #3850303

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

May 20, 2019 at 10:12 pm #3850509

aaronJ-5

The duplicator plugin is already installed from a previous support issue. Please feel free to use it.

May 21, 2019 at 6:24 pm #3858175

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I took a copy of your website and tested in on a local environment.

I was able to narrow down to issue between the Plugin Beaver Builder Plugin (Standard Version) Version 2.3.3 and WPML Multilingual CMS 4.2.6 while running the site only with these both plugin and the default Twenty Nineteen Theme.

I can see here that WPML does offer a language option inside of the language switcher for any page, even if it is not translated. This is not any WPML default behavior.

Excuse my question, but did you maybe apply anz custom coding to the plugin files?

I would kindly like to ask you to install a new version of the Plugin Beaver Builder Plugin (Standard Version) Version 2.3.3 on the following test site in order to test it with WPML on a fresh installation of WordPress.

One Click Login: hidden link

Please leave me a short notification once the plugin is installed.

Kind regards
Andreas

May 21, 2019 at 6:33 pm #3858285

aaronJ-5

Hello,
Thank you. I have not made any customization to the Beaver Builder Plugin, however the developer may have done so to fix some bugs. I added a fresh install of the Beaver Builder plugin to your site, as well as the Beaver Themer plugin (but it is not activated) as that is what I am using to output the header.

May 21, 2019 at 10:58 pm #3859105

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for installing the plugin.

I was able to investigate and there is not any compatiblity issue in regards to the WPML language switcher between Beaver Builder and WPML. The language switcher does behave as expected on the test site.

I am about to consult our second tier support about the issue and I will get back to you as soon I received feedback.

In regards to my question I was refering to any custom coding on any template file or plugin? I see you enabled a custom language switcher. Did you try to undo those changes to see if it somehow affected the behavior of the switcher in general?

Kind regards
Andreas

May 21, 2019 at 11:22 pm #3859149

aaronJ-5

Hello,
Thank you for the reply.

There is a small amount of custom coding in the theme functions.php file, I renamed Woocomerce products to Tours and filtered the display of products to be ordered by 'menu_order'. There are some minor HTML / style changes to a couple woocommerce template files, but no major functional changes anywhere.

Did you try to test for compatibility issues with WPML and the Beaver Themer plugin?

I'm not sure what you mean about a custom language switcher, the only thing I can think of is I did accidentally turn on a language feature in the Woocommerce Photo Reviews Plugin, (see photo), but I turned it off again almost immediately. However, it does look like it made some changes because I see a link to 'Show reviews in all languages (4)' on this page: hidden link (see 2nd photo)

I do not know how to make the link go away, and it doesn't actually show 4 reviews.

I tried disabling the Photo Review Plugin, but that does not fix it.

May 21, 2019 at 11:51 pm #3859239

aaronJ-5

I wonder if that Photo Plugin caused some comments to be translated for the New York page, and that is why the WPML language switcher stays active on that page? I don't know how to delete those translated comments, but that might be the cause.

May 22, 2019 at 3:47 am #3860595

aaronJ-5

I tried deleting the New York Page that had the issues altogether and creating a new page. But the issue still remains. So its not that. Also, I added a comment to a Product and got this error:
Warning: A non-numeric value encountered in /home/topdogt1/public_html/wp-content/plugins/woocommerce-multilingual/inc/class-wcml-comments.php on line 76

May 22, 2019 at 1:30 pm #3866149

aaronJ-5

Hello, I have decided to uninstall WPML and use a different translation option. Thanks for trying to help.

May 22, 2019 at 8:03 pm #3868935

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry to hear that you decided to not use WPML for this project.

Sadly, it was not possible to recreate the issue on a new installation with WPML. The theme was behaving without issues. As I also tested your site in minimal setup with a default them and expereicned the same issue, which for I do not think that it is realted to your child theme.

I am still consulting our second tier support for investigating about the issue, but as we can not recreate it is difficult to say, what is the issue on your site.

Maybe if you find the time you could check out the earlier mentioned sandbox test site and try to recreate the issue?

I will get back to you once I received more feedback.

Kind regards
Andreas

June 18, 2019 at 11:46 pm #4046787

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We did not receive any further feedback from you in regards to the issue between the TopDog Tours Theme and WPML.

Let us know if you do have any questions otherwise please consider this ticket as closed.

Kind regards
Andreas