This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.06 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 10 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 20, 2019 at 10:59 am #4422905

michaelS-26

I looked up the internet for the same issue and believe me - I tried it all -

* Deselected Auto register strings for translation
* Increased WP Memory limit to 265MB
* Increased the *MaxInputVars* of PHP settings to 10,000
* Updated everything to the last versions
* Disabled "Track where strings appear on the site"
* Deselected "Auto ID adjust state"

And I guess I tried few more things but none of the actually helped.
And also, when I try to scan one of my language pages with the Google Speed Test tool, I receive "Lighthouse returned error: NO_FCP. Something went wrong with recording the trace over your page load. Please run Lighthouse again. (NO_FCP)".. but when I scan my homepage (which doesn't use the WPML functionality) I get very good results..

The language pages take me around 20-25 seconds to load, and after monitoring the queries, I noticed that there are wpml queries that take around 3s-4s each (screenshots attached).

Thanks in advance,
Michael.

* And please notice that this is VERY URGENT!

August 20, 2019 at 11:40 am #4423173

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I suspect it might be some kind interaction issue, for this reason I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Activate the debug mode in WordPress by following the steps described here: https://codex.wordpress.org/Debugging_in_WordPress
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

August 21, 2019 at 9:07 am #4429267

michaelS-26

Hello,

Well, I updated all the plugins, flushed any cache, and basically did all the steps you mentioned above and eventually I got a clean wp site with Twenty Seventeed, with no plugins enabled at all (except the WPML of course).
What I get now in Google Speed Test is almost a perfect score for my root domain (no translations involved), and for the language pages (e.g. example.com/de) the error is finally removed but still it moves reallllllly slow (talking about 9-10 seconds for Time To First Byte).. and once again - no plugins enabled + basic wp theme with no modifications at all.
When I activate my theme back - I once again get these timeout and NO_FCP errors when running speed tests on my language pages.

So to sum it up -

Theme enabled + Plugins enabled = Homepage loads fine, language pages load extremely slow and Google's page speed test returns timeout errors on language pages.

Theme enabled + Plugins disabled = Homepage loads fine, language pages load extremely slow and Google's page speed test returns timeout errors on language pages.

Theme disabled + Plugins disabled = Homepage loads perfectly, language pages still load extremely slow and Google's page speed test returns 9-10+ seconds for Time To First Byte on language pages.

August 21, 2019 at 11:37 am #4430857

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

In this case I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

August 22, 2019 at 1:16 pm #4439615

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I visited the site and I can see that you have activated several languages, which might be causing the performance issue. Could you provide the languages you are planning to use in the site so we can remove the languages that might not be used?

Also, while run some troubleshooting steps in the site I got this error (see attached image). Could you deactivate Cloudflare while we are trying to solve the issue?

Regards,
Carlos

August 25, 2019 at 7:36 am #4453353

michaelS-26

Currently, there are no languages that might not be used in the future. Can you please elaborate more on these languages which 'might be causing the performance issues'?
Maybe we can be more specific with how we approach to this problem.

August 26, 2019 at 9:22 am #4457137

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

What I suspect at this moment is that so many active languages could be causing the site to be that slow.

In order to check if this is true I would like to ask you to follow this steps:
- Create a full backup of the site.
- Remove all languages except 2 or 3 (leave the default language active) -> Save the changes

If the issue disappeared then I would recommend to add the other languages when you have a translation for them.

Could you tell me the results of the steps above?
Regards,
Carlos

August 27, 2019 at 7:42 am #4463437

michaelS-26

Yes. We realized that having many active languages may cause the problem, but that's exactly the case - We *do* have many languages - and we do wish to keep it that way, since all these languages are functioning and are part of the whole business.

How would you approach this problem in case we do need all these languages and can't remove any of them? Multisite? Subdomains? Split the DB somehow? I mean - Haven't you dealt with these volumes of usage before?

August 27, 2019 at 10:49 am #4465385

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I personally haven't see this amount of languages in a site before. My first approach will be a faster environment, and -just for testing purposes- I would try the latest beta release of the plugin, because the new String Translation version changed lots of it's core functionality and should eliminate the performance issues associated to it.

Regards,
Carlos

August 28, 2019 at 1:09 pm #4474431

michaelS-26

What is the right approach to remove unnecessary languages from WPML?

August 28, 2019 at 1:13 pm #4474513

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please visit this post where you can find a similar question and the steps to follow: https://wpml.org/forums/topic/delete-language/#post-1411520

Regards,
Carlos