This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by eliasS 1 year ago.

Assigned support staff: Ricardo Alday.

Author Posts
October 16, 2018 at 4:45 am #2819668

eliasS

Link to a page where the issue can be seen: hidden link

When I click on next page, instead of switching to the next page in the pagination of the article, I'm being turned back to the original article. My original language is german and second language is english.

I press on the next page link on this site: hidden link

And it brings me to this site instead of loading page 2: hidden link

October 17, 2018 at 3:15 pm #2825108

Ricardo Alday

Hi,

Thank you for contacting WPML support.
I will need to take a look at the theme code that generates the pagination links in order to determine what's causing this. For that, I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Please let me know exactly what steps should I follow to see the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.
Ricardo

October 18, 2018 at 9:59 pm #2829722

Ricardo Alday

Thanks. I tested the plugin you're using to create the pagination: Theia Post Slider but I'm afraid it's not compatible with WPML. The only way I got it to work was to change the "Language URL format" settings in WPML from "Language name added as a parameter" to "Different languages in directories".

Hope that helps.

October 18, 2018 at 10:44 pm #2829767

eliasS

My issue is resolved now. Thank you!