Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Divi blog module Pagination not working with WPML

Solution: under WPML > Settings >Post Types Translation, make both the post and pages set to "Translatable - only show translated items".

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by lauraN-2 1 year, 9 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
December 17, 2018 at 2:13 pm #3008612

lauraN-2

Hi! We're currently experiencing a bit of an inconvenience on our blog page. Because we've got the pagination switched on and we do get the button "Previous page" at the bottom of the page but it just leads to the blog page. There's also no "Next page" Option... When we turn off pagination and choose to show more blogs that works fine but we'd prefer to be able to show multiple pages due to performance speed for example.We contacted our Theme provider but they managed to find out it was an issue to do with the WPML plugin. Could you please help use figure out how to fix this?

hidden link

December 18, 2018 at 7:23 am #3011149

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our support forum, I will be helping you with your issue.

It will be useful if I can get more information, Please let me know if you can temporarily change the permalinks to default does it work or the issue persists?

Please provide us with WPML debug log to know about your setup and identify any known issue. Follow the link on how to share debug log
https://wpml.org/faq/provide-debug-information-faster-support/

Thank you.

December 18, 2018 at 10:31 am #3011631

lauraN-2

Here's the debug info, unfortunately I can't set the permalinks to default. As soon as I do every page gives a 404 error. We're looking into how to fix that 🙂

December 18, 2018 at 11:37 am #3011800

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I hope you have reversed the permalinks and got it fixed 🙂 Sorry for the trouble.

Can you please check whether you have Ajax operation enabled in WPML?
Goto WPML > Languages >Language filtering for AJAX operations Enable the option Does it help ?.

If not then I might need to investigate further for this I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behavior?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, kindly temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Recomended: Backup ur stie and database

Best Regards,
Raja

December 18, 2018 at 12:14 pm #3012003

lauraN-2

It didn't work, I don't see the option to reply privately could you enable this?

December 18, 2018 at 12:20 pm #3012016

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry, I have enabled it now. Thanks for the additional information.

December 19, 2018 at 5:57 am #3014879

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,
Thanks for installing duplicator, I'm using the clone on my local setup to test your site. I will get back to you once I have an update.

Best regards,
Raja

December 19, 2018 at 2:37 pm #3016927

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

I'm able to reproduce the issue in my local setup, I have requested our second tier supporters to have a look into for a detailed investigation. I will let you know once i have some update from them.

Thank you.

December 20, 2018 at 1:04 pm #3020825

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi There,

Thank you for your patience,

We are able to fix your issue. A slight change in WPML settings is done in WPML > Settings >Post Types Translation, we have made both the post and pages "Translatable - only show translated items". Which solved the pagination issue.

Please check the attached screenshot for the change in the setting.

Please leave us feedback if your issue is resolved, if you need further assistance we will be happy to help you :).

Thank you and best regards,
Raja.

December 20, 2018 at 1:18 pm #3020869

lauraN-2

My issue is resolved now. Thank you!