If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Peter 2 months ago.

Assigned support staff: Andreas W..

Author Posts
September 10, 2019 at 9:03 pm

Peter

Hi all,

I have a problem on my site with a filter plugin and the translation. I use Jet SmartFilters by Crocoblock. I have a filter listing to display tours. I translated all necessary parts and strings but when you click on the pagination for the filter, it switches to the 2nd page of the English original instead of the 2nd page of the translation.

Link to a page where the issue can be seen: hidden link

Where am I mistaking?

Thanks for any hints!

Peter

September 11, 2019 at 3:39 pm #4554857

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

I am not sure if I am understanding the issue.

I went to hidden link then selected a filter for type of tours and switched through the pages of tours. All tours have been displayed correctly.

I then tested the same on the English and Ukranian page without issues.

Could you please calrify more about the issue in order to be able to assist you further?

Kind regards
Andreas

September 14, 2019 at 8:42 pm #4573179

Peter

Hi,

I am not sure why it works for you. It does when a user is logged in. But I just asked 3 friends without a login to check it and they confirmed that in the German, Ukrainian and Russian versions page 2 and 3 show the English listing. I attached screenshots to show what I mean.

September 16, 2019 at 4:13 pm #4582529

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have enabled the option "Store a language cookie to support language filtering for AJAX" at WPML -> Languages -> Language filtering for AJAX operations.

The issue seems solved now.

Is there something else I can do for you?

Kind regards
Andreas

September 16, 2019 at 4:20 pm #4582623

Peter

My issue is resolved now. Thank you!