This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When trying to translate products, I get redirected to the translation queue instead of to the translation editor for the product.

Solution: There was a duplicate entry error in the database, so I resolved that by deleting the duplicate translation. I also found a missing column in the icl_translate table, so I created the column that had been missing. Now, when I go to WooCommerce Multilingual and click to edit a product translation, the translation editor opens up.

This topic contains 12 replies, has 2 voices.

Last updated by fabioD-21 1 month ago.

Assigned support staff: Lauren.

Author Posts
September 13, 2019 at 5:43 pm #4570273

fabioD-21

Hello,

we are facing a problem with WMPL on the website stefaniaesse.com. I'll try to summarise the last two days, hope my English will be good enough!

We have the domain stefaniaesse.com and a testing site named areatest.stefaniaesse.com

In August we put some new contents (both in Italian and English) on areatest. When our customer said ok to the new contents (we are talking about very, very small changes in the structure of the pages - like putting a more updated picture instead of an older one - and adding new products to the eShop), we started to put them on stefaniaesse.com too.

After we had completed the work on contents on areatest, updates of the WMPL plugins had been released: we did the required updates (everything else on areatest was already at the last versions - from WP to the theme and all other plugins), but had not to translate on areatest anymore... One funny thing had happened while we were doing this updates: and error message occured, it said that the update had gone wrong. BUT on the dashboard the message that informs of the availability of updates had vanished... and if returning from dashboard back to the page that lists all the plugins, the last versions of WPMLs resulted as installed! We didn't give importance to it and started to work on the new contents on stefaniaesse.com

Unfortunately, after having edited all the new products in Italian on stefaniaesse.com, we faced the problem: couldn't translate the WooCommerce products anymore and if trying to do it, through the classic editor as we have always done, the system sent us to the translations queue - never happened before! In the translations queue, moreover, we couldn't even find those new products, already created and published both in Italian and English, and on whose translations we were trying to work. It also said that the user hadn't the right to translate (never happened before! With my username I had already translated all the website and, in a second time, the eShop, and also two different collections in different moments...!). Tried by configuring the user as translator, tried to login in with another Administrator, tried everything I found on WMPL forum, results: 0.

Then yesterday, always on stefaniaesse.com, (if I'm not wrong, the evening before we had downloaded the backup of the previous day) we noticed something strange on the Plugins page, that is reported in the image here uploaded.

When we realised this anomaly, we remembered about the error message during the download of the updates of WMPL plugins!!!

Took a look on WPML forum and red this: https://wpml.org/forums/topic/the-last-update-4-2-7-1-has-a-problem/

So we contacted our partner consultant for WordPress and decided to reinstall WMPL as suggested in the forum.

Firstly we tried to reinstall WMPL on areatest.stefaniaesse.com (since in the mean time we had found that translating wasn't working anymore there too and that the anomaly resulted also there!) and everything ran perfectly! The problem was solved, wow! Thanks WMPL forum, we love you!!! BUT THEN... unfortunately, when we did the really same procedure on stefaniaesse.com... something went wrong. When reinstalling WPML the system says that everything had gone fine, no error messages, nothing apparently wrong. But in fact, the problem (impossible to translate) persists. No one understands why!

We have contacted OVH, our hosting provider, they checked and said that by them everything is ok. What do we have is this the following report that we receive if we try - without succeeding - to translate:

Un errore di E_ERROR è stato causato nella linea 41 del file /home/stefaniadk/www/wp-content/plugins/wpml-translation-management/classes/translation-jobs/class-wpml-tm-unsent-jobs.php. Messaggio di errore: Uncaught TypeError: Argument 1 passed to WPML_TM_Unsent_Jobs::prepare_unsent_job_for_notice() must be an instance of WPML_Translation_Job, boolean given, called in /home/stefaniadk/www/wp-includes/class-wp-hook.php on line 286 and defined in /home/stefaniadk/www/wp-content/plugins/wpml-translation-management/classes/translation-jobs/class-wpml-tm-unsent-jobs.php:41
Stack trace:
#0 /home/stefaniadk/www/wp-includes/class-wp-hook.php(286): WPML_TM_Unsent_Jobs->prepare_unsent_job_for_notice(false)
#1 /home/stefaniadk/www/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#2 /home/stefaniadk/www/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#3 /home/stefaniadk/www/wp-content/plugins/wpml-translation-management/inc/translation-jobs/helpers/wpml-update-translation-data-action.class.php(114): do_action('wpml_tm_new_job...', false)
#4 /home/stefaniadk/www/wp-content/plugins/wpml-translation-management/inc/translation-jobs/helpers/wpml-update-translation-data-action.class.php(60): WPML_TM_

May you please, please, help us to solve it? Our customer is waiting for us to edit on its eshop the new collection and we really don't know what to do now. We'd love not to be forced to migrate the areatest on stefaniaesse... 🙁

In the mean time we had also upgraded PHP to 7.3 (it was 7.0), but nothing changed.

If you need to login to the website we'll give you the access, would be glad to! 😀

Thanks in advance for you support.

All the best,
Gaja and Fabio

September 13, 2019 at 5:56 pm #4570327

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Once you have had a chance to run the cleanup steps as mentioned in our chat, please let me know if you are still experiencing the issue. Thanks!

September 15, 2019 at 2:10 pm #4574857

fabioD-21

Hello Lauren

we carefully followed your instructions, unfortunately nothing changed. The situation is still the same...

What can we do now?

Thanks a lot for your support!

Gaja

September 16, 2019 at 4:25 pm #4582639

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay, let's try this. Please deactivate and delete all WPML plugins. This will not delete the translations.

Then, download just the core plugin (Sitepress Multilingual CMS) from http://www.wpml.org/account/downloads and install this fresh download.

Once it is installed and activated, go to WPML -> Plugins and click the Commercial tab. Then, click Check for Updates. Now, from this screen, activate one at a time the add ons that you would like to use.

After these steps, are you able to edit the product translations?

September 17, 2019 at 10:01 am #4587395

fabioD-21

No... still facing the problem 🙁 Do you want to access the site or there is another procedure that we can try?

Once again, thanks a lot for your support!

September 17, 2019 at 10:46 am #4587771

fabioD-21

Hi Lauren, after my last reply I tried again to manage a product' translation (as I said, I am not the one who is actually trying the procedures) just to be sure that really nothing had changed. I confirm it didn't. I don't know if the following details might be helpful for you, but the situation is dual:

A) If I try to translate (technically it would be an update of the translation, since I had duplicated the product from Italian to English) one of the products we have created in the last weeks, it appears a message that informs that there is a malfunctioning and all I can do is to go back to the WooCommerce Multilingual.

B) If I try to translate one of the two fake products that I have created last week after the first reinstalling of WPML, it sends me to the "Coda delle traduzioni" (translations queue)... where I shouldn't be sent (never have been sent there before this mulfunction)... but, moreover, in there I don't even find any trace of the above-mentioned two fake products neither of those new products that I had created in the last weeks (see point A). In there I can see just the very old ones, created (and translated) several months ago.

Hope it can help in some way.
I remain at your disposal for any further detail.

Have a nice day
Gaja

September 17, 2019 at 12:19 pm #4588403

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 18, 2019 at 1:31 am #4591449

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for sending me credentials. I found that there was a duplicate entry error in the database, so I resolved that by deleting the duplicate translation. I also found a missinc column in the icl_translate table, so I created the column that had been missing. now, when I go to WooCommerce Multilingual and click to edit a product translation, the translation editor opens up.

Please also note that I created a test translation account for myself. You will need to add your translation managers and translators at WPML -> Translation Management -> Translation Roles.

I also tested by sending Midsommer product to translation, and I can now see it when I go to WPML -> Translations.

Please let me know if you need any further assistance and I will be happy to help.

September 18, 2019 at 1:33 pm #4597129

fabioD-21

Hello Lauren, thank you very much for all that you've done! Unfortunately, I have both good and bad news.

I added myself as translation manager, then I moved to WooCommerce Multilingual and tried to translate the products: with some products everything worked (yeheeeeee!!! Happy us!), with some others I have been sent to the translations queue again and couldn't translate...

I am not sure anymore (really not at all) about it, but these still-problematic products might have been created (or in some way modified) while we were already facing mulfunctioning... I haven't tried to delete the English version of those products neither the Italian, haven't touched them at all preferring to confront with you before doing anything! I didn't want to risk to create some brand new problem, now that it seems we're about to see the light at the end of the tunnel!!!

So, these are the products that I still COULDN'T translate (here reported following the order they are listed in on the website, from bottom to top): Notte, Luce Eterna, Shimmer (category Cappe), Dark Shimmer, Shimmer (category Kimono), Wonderlust, Orka, Blush Rose (category Knit), White Blush (category Knit), Smorboll, Likke. I couldn't traslate neither those two fake products, created by us during the past days as testing.

Instead, these are the products that I have just SUCCESSFULLY translated (here reported following the order they are listed in on the website, from bottom to top): Luce, Lagom, White Blush, Hematite, Midsommar.

To be sure, I have also created and SUCCESSFULLY translated two brand new products: Midsommar (category Gonne Pantaloni, it's a pair of pants), created by duplicating the Midsommar shirt (the one you have tested); and Blush Rose (category Gonne Pantaloni, it's a wallet skirt), created through "crea nuovo prodotto" (create new product).

What can we do to solve the issue? Should I try by deleting those products that still give problems, then remove them from the trash and create them again, from scratch? If this is the procedure, should I do that just for the English version or it is better to delete also (before) the original in Italian?

I really do hope that this will be the last step to the full resolution of the problem. In any case, we do really thank you so much for your support. You have been very patient, kind and helpful all the time!

Gaja

September 18, 2019 at 1:47 pm #4597241

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for the additional testing and for sending me an update. It looks like we are making progress.

Let's try this. For ONE of the products that you are still unable to translate, please try deleting the current translation and then be sure to remove it completely from the trash. Then, if you try to create a new translation for that product, are you able to do that? If not, let me know which product you tested this on and I can take a look into the database and try and figure out what is happening there.

Please let me know the results once you are able to test this. Thanks!

September 18, 2019 at 6:29 pm #4599527

fabioD-21

I should have clicked on "My Issue is resolved", but before I wanted to say the final THANK YOU, Lauren!!! You are the best supporter ever! Is there a public section for reviews about supporters? Because we'd be glad to leave an enthusiastic feedback!

I made the following tries, always succeeding!

Firstly, following your instructions, I deleted the English version (from trash too) of the product NOTTE. Then opened the Italian version and proceed to create a brand new English version (turning on OFF the WMPL Translation Editor "thing" and duplicating the product, as usual). Moved to WooCommerce Multilingual and the NOTTE was finally working! I could translate it successfully!

After having completed the translation, I also tried to make a text change in the Italian NOTTE, then moved back to the English and could report the change there too!

I haven't already tried with the other today's still-problematic-products, but... I decided that at this point I can be a little optimistic and relaxed! (moreover, here in Italy now it's 8.30pm... this evening we have reached an important goal thanks to your support, I'll go on with deleting and re-creating rebellious products tomorrow morning 😀 ).

After the success with the NOTTE product try, I realized that in these days we hadn't tested the very old products (but I already know that in the following weeks it might be that there will be updates or other changes to do, on those too). So, I tried to make a change in the description of the Italian DUNE 01, then moved back to the English and could report the change there too successfully.

Is this the proverbial light at the end of the tunnel? Looks that way!! THANK YOU!!!

Best regards

Gaja & Fabio

September 18, 2019 at 7:15 pm #4599685

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you so much for your kind words, I'm just thrilled we were able to resolve this for you! You are welcome to leave feedback once the ticket is marked as resolved, and I much appreciate it in advance.

If you come across any issues as you continue translating products, please don't hesitate to open up a new chat or forum ticket and we will be more than happy to help.

Have a wonderful evening 🙂

September 19, 2019 at 2:53 pm #4606627

fabioD-21

My issue is resolved now. Thank you!