Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Dražen Duvnjak 1 month, 1 week ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
April 19, 2021 at 5:41 pm #8575083

carlotaC

Hi I have an Issue with URLS. I've configured WPML to use directories, but if I put ?lang=br or ?lang=es I got an error and not a redirect

April 21, 2021 at 8:57 am #8588781

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I have checked your issue and could see why this could be confusing. But the issue is not on WPML actually, nor is it an issue. That is just query string in URL works.

If you for example add ?test=lat, and check without WPML it would still load some page, at least that is happening on my test website.

In most cases it should load the same page/URL, please check for more info:

- hidden link
- https://stackoverflow.com/questions/39266970/what-is-the-difference-between-url-parameters-and-query-strings

I suggest you check without WPML plugins and by adding some other custom query string, to confirm the same behavior on your website also.

I hope I was helpful. Don't hesitate to ask if you find any problem along the way, I'll gladly help you.

Regards,
Drazen

April 21, 2021 at 10:32 am #8589577

carlotaC

Hi Drazen,

If I deactivate WPML plugins:

  • hidden link It goes to homepage
  • hidden link It goes to homepage

If I activate WPML Multilingual CMS and WPML String Translation plugins:

  • hidden link It goes to a extrange page
  • hidden link It goes to homepage

See the snapshots

So the behaviour changes when activating/deactivating WPML plugins

Discover_YouTubers_Life_2__and_add_it_to_your_wish_list_y_Hi_Drazen__•_Untitled-3.jpg
Discover_YouTubers_Life_2__and_add_it_to_your_wishlist_y_Hi_Drazen__•_Untitled-3.jpg
April 21, 2021 at 11:15 am #8590011

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello Carlota,

thanks for getting back and investigating the issue further.

Okay, yes that doesn't seem to be excepted, and I would need to check and debug on it further.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply. You can safely add your information into these fields.

Thanks,
Drazen

P.S.
Please do not open new tickets or chats for this same issue. This current ticket came from chat, as it was not possible to solve it in a chat session, it needs a bit more investigation, which is why it was turned in the ticket.

April 21, 2021 at 12:20 pm #8590541

carlotaC

Hi Drazen,

For company policy, I can't give you access to the project.

Is it ok if I give you a complete dump of database and code?

April 21, 2021 at 12:58 pm #8590935

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I understand, we have a suggested way for it.

Can you please then provide a Duplicator copy of the site following next documentation:

- https://wpml.org/faq/provide-supporters-copy-site/

I have enabled a private reply for you.

Thanks,
Drazen

April 29, 2021 at 2:31 pm #8655449

carlotaC

I'll send you the site next week.

Thanks

April 30, 2021 at 5:54 am #8659733

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

sure, whenever you can.

Kind regards,
Drazen

May 10, 2021 at 7:15 am #8725795

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I have tried and I can see it happens only with Avada and on the homepage, other pages work fine.

Also, I have tried reproducing the same on the sandbox, but there it works fine.

I have shared all info with our 2nd tier support to check and advise.

I will update you soon.

Thanks,
Drazen

May 10, 2021 at 10:05 am #8727567

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

we checked further and managed to find the problem.

It seems it is a know issue and we will be providing a permanent fix in the future versions of WPML.

You are not being redirected to the broken page but to the Post page, since you have not set it, it returns a broken page. If you set it inside Settings > Reading, you will see the latest posts page.

As a workaround, and since this happens only on the homepage I suggest you create a redirect rule using the Redirection plugin for example: e.g. hidden link should go to hidden link.

From my side, I will be adding this ticket to our internal system and notify you when I have some news on the permanent fix.

Thanks,
Drazen

May 12, 2021 at 3:55 pm #8750773

carlotaC

Hi Drazen,

When do you expect to have this issue solved?

May 13, 2021 at 5:42 am #8753803

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I do not have ETA to share, but it will probably take some time.

As I suggested in the last reply you can use a workaround and redirect mentioned URL and fix this issue.

I will update you when I have more news.

Thanks,
Drazen

May 13, 2021 at 7:49 am #8754215

carlotaC

Hi Drazen,

Understood, but I have some doubts. You told me:

As a workaround, and since this happens only on the homepage I suggest you create a redirect rule using the Redirection plugin for example: e.g. hidden link should go to hidden link;

The thing is it happens all the time, no matter what chain I put after the ?lang=

For example if I put hidden link happens the same or hidden link, so I cannot redirect every possible result.

Any advise here?

May 13, 2021 at 8:46 am #8754683

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for getting back.

I suggested setting that redirect if you have 404 error logs or users visiting that link if you have used that URL lang parameter in the past.

Otherwise, all other links are not visible to any user or search engine, so they can not know it exist, since they do not appear anywhere, so I don't believe any user will go to the link: hidden link

Such an issue will not cause any issue to your visitors or SEO, it is purely a cosmetic issue.

Also, as said it is reported to developers and we will be fixing this in future versions, but can not give any ETA, and since it is a cosmetic issue it might take time before it is fixed.

I will update you.

Thanks,
Drazen