Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When I switch to the secondary language, the page where I have a Toolset View displayed, doesn't show the content properly. Part of the posts disappears as well as the images. Solution: Make sure that the translation progress is at 100% and that the Duplicate featured image to translations option is checked for all the boats.

This topic contains 4 replies, has 2 voices.

Last updated by danielJ-53 4 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
July 9, 2019 at 6:20 am #4167661

danielJ-53

Hi,

It looks like there is some kind of incompatibility with Toolset. When I switch to the secondary language, the page where I have a Toolset View displayed, doesn't show the content properly. Part of the posts disappears as well as the images (please see the screenshot: Toolset View-1 / Toolset View-2).

Thank you.

July 9, 2019 at 1:38 pm #4171305

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Daniel,

I checked the Spanish version of the page that you captured in your screenshot (hidden link) and I could see that a few boats are working well and display all the elements. Can you edit the boats that you have issue with, edit the translation, and make sure that the percentage from the bottom side is at 100%, please? I just did this for the GOBBI ATLANTIS 55 boat and, as you can see, it's displayed very well now in Spanish. Just give a try for the other boats and let me know how this works.

Thanks,
Radu

July 10, 2019 at 3:17 am #4175663

danielJ-53

Hi Radu,

Thank you for writing back!

I've just done what you've told me to, edited all posts (translation - 100%) and it worked for some of the results, but there are still a few posts with the same issue 🙁

July 10, 2019 at 4:14 am #4175955

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Daniel,

It seems that we're on the right track!

Now, can you edit the English version of the boats that are still missing the featured image and make sure that the Duplicate featured image to translations option from the right sidebar is checked, please? I did this check for the Lisa IV boat. Once I checked this box, hit the Update button, edit the translation, and press the Save & Close button, everything went back to normal on this page hidden link. Can you check all the other boats and try to do the same change for them too, please?

Thanks,
Radu

July 10, 2019 at 1:09 pm #4180535

danielJ-53

Issue solved! No I understand that I have to pay attention to a lot of details and make sure everything is set up equally for both pages (original and translated). Thank you!